Litter Robot 3 Connect DFI issues, missing, blue flashing light, not working

I recently purchased a litter robot 3 connected and the litter robot has been working perfectly up to this point, however, since I did my first litter empty the unit will not reset properly. I have the flashing blue light constantly. I press the reset button and I can get the blue light to remain steady but after one cycle it is back to flashing and indicating the drawer is full.

I have followed all troubleshooting techniques from the support site, including pulling the power leaving it for over 30 min in hopes to reset the code, resetting to factory defaults, removing bags and replacing with empty litter robot bags, cleaning the DFI lenses, trying the reset with drawer in and out. However, flashing blue light returns after one cycle. So at this point I need some technical support.

Now with all that being said, I did check last night the DFI lenses once more and discovered something interesting and also somewhat concerning. Based on what I have read and pictures online of the DFI circuit boards and replacement parts, it appears there is supposed to be 2 small circuit boards, one in each of the clear plastic lenses in the drawer area. One has the circuit board, the other does not! The only conclusion I can come to is that during the operation in the last few days or during the litter empty function the entire circuit board was dislodged and knocked into the drawer with all the other litter and waste. This is somewhat concerning as this is a very new product and seems to be already falling apart, and it would seem that perhaps the design of how the litter is falling down the chute, either normal operation of empty cycle has enough force to dislodge just the one DFI circuit board and leave everything else intact. This unit hasn’t even been operating for a month and this would classify to me as a pretty severe failure as the DFI circuits are at least $100. If this is a component prone to failure in this way this is not good.

I have heard back from support indicating that the new models only come with one DFI circuit board and use a laser to operate properly. I have no idea if this is true or not since a DFI circuit replacement per the website does not have a part like this, and I cannot find any literature on this either.

Any help here would be awesome.

Hi @ArcticThunder and welcome to the forum.

Your requested is being processed in our internal support.

You will receive the answers via email.

Thank you.


I have basically the same problem with my litter robot 3 connect. I have tried everything within the trouble shooting like the person said above, I’ve only had it for 1 week. As well I’ve tried to level out the floor for the sensor. But the main problem I am having is the connect only connected to the app successfully for 3 days. And then any time I tried to connect it and the power button would go from the blue to the red quickly.
I checked all parts and nothing was dislodged in shipping. I also contacted but I bought it from robotshop with the extra warranty.

Not sure what to do now

Me too. I have the EXACT same problem. I submitted a private support ticket and it was closed and said “being processed in our internal support.”… still waiting for an email.

Oh man. That sucks. And as of this morning it won’t even turn on. So I’ve tried the power cycle again. So I have left it unplugged for an hour.
And still not working.

The litter-robot site is looking for my order. But I said it’s through robotshop. Cuz I’m in Canada. So we will see what they say.

1 Like

Oh my gosh, I’ve been having the exact same issue!! I purchased the Litter Robot from the canadian site as soon as it became available (October 29th). I’ve been struggling with the drawer full indicator for weeks and have been too busy to contact support. Like you ArcticThunder, I only have one DFI sensor! It is the one on the right. I noticed this very early after getting my unit and thought it was strange that the left one was just an empty plastic slot. My unit only worked correctly for about a week and I’ve been struggling since with minor successes for a few days of normal use.

I have also emptied the unit, cleaned the entire unit including the DFI sensor after disassembly, unplugged the unit, factory reset, and resetting the cycle with the drawer out. I love the unit when it does work but it’s starting to seem like mine is defective. Has anyone else heard of this single DFI sensor, and is it always the one on the right?

Many thanks!

Yep, mine worked perfectly for a week also and then I have been struggling to solve this issue ever since.

Seems like it might be a batch of them that all have the same defective issue.

Hi there,

You may want to read the following blog:

This is a step-by-step guide to install the Upgrade Connect Kit to a regular Litter-Robot III.

You will read in the beginning of the guide that the Connected version is now equipped with a laser DFI sensor which has one board only.

Concerning the blue light:
The app uses an algorithm to estimate how full the unit is based off the number of times it normally has to cycle for the unit to be full. The unit does know when the drawer is totally full but anything before that is an estimation. Over time, once the app has compiled more data, the estimation will become more accurate. I would say everything is fine but to keep an eye on it over the next week or two.


How do I reset so the algorithm starts from no information at all?

I would presume that all the issues of drawer full after nearly every cycle has given bad data to the algorithm and therefore it is giving false positives all the time. Without a reset of this data it would be safe to assume that the problem will persist.

I’m having the flashing blue light issue as well. This occurs even without the drawer inserted. I’ve cleaned the lenses and everything around them twice now, but as soon as I power it on, the blue light flashes right away. If I press reset, as soon as it works once the blue light flashes again. It’s been doing this since the first day I bought it. Can you help me?

1 Like

This is beginning to sound like a design flaw. Has anyone heard back from RobotShop about this issue yet?

If your unit is still under warranty and/or was bought with RobotShop, let me know.

I will create an internal support ticket and take care of this situation.

I am currently experiencing this issue and was told my trouble ticket was closed and it would be converted to internal but I never received any emails or follow ups. That’s why I am in this thread.

I opened a support ticket and they told me that the learning algorithm will get better on it’s own. They confirmed that the new machine has only one sensor that is laser driven and will tell you when it is absolutely full, but that it’s the algorithm that needs to improve. This makes absolutely zero sense - how will it possibly get better when I can’t give it any accurate feed back? I emptied my drawer two days ago, pressed empty drawer on app and pressed reset button on unit. Works for two days and now it says it’s full - great, what do I do now? Tell it I emptied it when I don’t? Empty it early? Ideally I would be able to tell it “No, you are only 1/4 full”

Beyond frustrated…

1 Like

I’m trying the below based on what some other LRC users have said.

Basically to improve/correct the data gathered by your litter robot you have to

  1. let it do its cycle once the cat has used it
  2. If you get a bin full notification, check the drawer.
    If it’s not full then press the reset button on the litter robot (not on the app)
  3. Repeat steps 1-2 until the bin is actually full
  4. Once the bin is actually full, press the “reset gauge” on the app and reset on the unit

So going by this, I think you can let the litter robot know that “No, it’s not actually full yet.” By pressing the reset button on the unit and by not pressing the “Reset Gauge” button on the app until you actually have a full bin.

I’m trying this now and hopefully it will improve over the next few days.


Got my robot last week and I have the same problem :unamused:

I have the same problem as well, think I should have purchased the cheaper robot & just check every few days manually as I still have to check anyway which to be honest defeats the purpose of the app :see_no_evil::woman_shrugging:

1 Like

Hi everyone,

Apologize for the delay.

I receive really interesting update from Litter-Robot.

To reset DFI sensor fault on a Connect Litter Robot please hold Reset button until the blue light blinks quickly. After that, it should come to solid blue light.
This should really fix the issue of the DFI.

1 Like

@pjutras yes it resets it back to solid but every time now after my unit cycles it continues to flash as if full when not. I have to manually press the reset button after the cycle to stop the DFI flashing light…

I have done all the troubleshooting and I still get this. Just started happening in the last few days and I’ve had this litter robot since November 2017.

Anything else I can do I guess besides pay for the $80 replacement kit?

1 Like

Hey @Rutoy21,

If the troubleshooting doesn’t solve the issue, then DFI sensor should be replaced.

Are you still in warranty?