VADER Spider Controller Arduino Upload Issues

Service_Droid_Wiring_Diagram__Vader_Version_3_0.pdf (378954Bytes)

So it's been a while since I last got a chance to work on VADER (see , but I recently was able to dust him off and finish up the wiring. VADER is a Service Droid mounted on a Rover 5 Base with a 4 channel motor controller and a Spider Controller.

After implementing the wiring according to the wiring diagram I had created (see attached and  I put together a bare bones code to test the servos in the Service Droid to verify it was all wired correctly. It was at this point that I hit a very annoying wall.

When I upload the code to the Spider Controller the Arduino editor gives me the following error:

avrdude: stk500_getsync(): not in sync: resp=0x00

During the compiling time L1 (red) is blinking until the upload starts. During the upload L1 pauses (off)  and all the while L2 (blue) is steady on.

As I understand it, this error is telling me that something is preventing the computer from talking to the arduino controller - either the computer, the cable or the arduino itself has decided not to play nice.

Across the internet I find a lot of references to people getting this error in various Arduino boards and there are almost as many opinions on how to fix it. I think I've tried them all except reburning the boot loader on the Spider. I'm hoping to not have to come down to that. I tried two different USB cables and two computers. The one I'm currently on is running Windows 8 (unfortunately). I've hit the Reset button on the Spider at various times during the process without changing the results.I've tried reboots of the Arduino editor, the computer and the board.

I'm gonig to keep trying, but in the mean time if anyone in LMR-land has ideas I'm all ears.



I lost 2 hours last time

I lost 2 hours last time with this error. Turned out I forgot to select the correct board.

I know that error all to

I know that error all to well. Unfortunately I whole heartedly believe it has never been the same fix twice for me. Once it was a cheap USB cable, but the majority of the others I think it was a windows issue. after a reboot, and restarting the IDE, double checking the port matched the cable, it all seemed to work again. Yay Windows.

Thanks for the feedback! I’m

Thanks for the feedback! I’m going to spend some time ensuring the right drivers are installed before I reburn the bootloader. I’ve read the Windows 8 can have issues with drivers used to talk to the Arduino. I’ll let you all know how it goes.


And the winner

And the winner is…


I had read that the Spider used ATmega1280 so it didn’t occur to me to try ATmega2560. That turned out to be the trick!


Thanks guys!