Litter-Robot II Advanced Troubleshooting Guide | RobotShop Community

@Jeff It seems you are having two different problems. First one, you would probably need a new harness to fix the globe problem. Second, if you do not have any lights on the control panel, we suggest you to replace the circuit board.

When I turn on my litter robot the yellow light comes on and it won’t change cycles when i press the buttons. After a few minutes, the red light comes on flashing. Also, the motor starts to move but stops immediately.

1 Like

I would love to send my LRII in to you for repair, but unfortunately I did not purchase it with you. Can you possibly offer some advice? I’ve read through both of your trouble shooting guides, and believe the problem is (probably) the motor, which I’d like to replace. However, I’m stymied because I can not remove the base of the litter robot. I purchased a Torx T-20 driver to remove the base, as you suggested, but the TX-20 isn’t effective - it appears that the screws on the LR base have been replaced by tiny little bolts (a smooth head with a tiny round hole in the center). No tool I have would seem to be effective. Without removing the base, I can’t further check the magnetic sensors or the motor. Do you have any suggestions?

(Part II) And I supposed I should have described the problem - sorry. The robot rotates almost a full cycle, but before completing the cycle, it stops in place and all three lights start blinking. I’ve checked the weight sensor at the base (it appeared to be missing the nut, but I replaced that) and have checked the circuit board and safety wire. The motor sounds like it’s straining. I can’t go any further until I can remove the base, but, as I noted in part 1 of this post, I can’t seem to do that.

@Pete The little bolts you are describing are in fact Rivets. You can use a drill and drill them out of the Litter-Robot. You would then need to replace them with screws. From what you are describing, it does seems like the problem you are experiencing is caused by the motor.

@Sean We would suggest you to verify the cat sensor and the safety line sensor, to verify if they are working correctly. If so, the problem can be caused by the motor as well.

@ Matthew Thibault, thanks so much! That’s what I will do. I’ll be back in touch to order parts once I open her up!

@ Matthieu Thibault. Thanks again for the advice - I was able to easily drill out the rivets, as you suggested, and open up the unit. All the wiring appears intact and in place, the hall sensor is in place, and the circuit board is clean. I removed the motor and opened it up, and all the gears were intact and (reasonably) clean. The gears seem to move fine when manually turned. I reinstalled everything, and the problem persists (completes its first rotation, but then stops partway through it’s second reversed rotation, and all three panel lights blink about once per second). Do you still believe it’s the motor? I always thought motors either worked or didn’t - I didn’t realize they could work in a reduced fashion (one of the many reasons I’m not an engineer). If it sounds like the motor to you, I will order it today. It does always sound like it’s on its “last legs.”

This is great stuff. Quick question: My globe rotates forward fine but slows in reverse as if under an enormous load. The reverse is so slow that the machine times out and all three lights eventually blink. Any ideas? There are no obvious obstructions, and the drive gear and axle have no obvious or apparent deformations. Could this be the circuit board, maybe a power transistor going bad? Or would it be the motor? Thanks!

@Pete Thank you for the information. We cannot guarantee it since we do not have the unit physically in front of us, but it does seems the problem is caused by the motor.

@Mathieu. Thanks! Ordering it now!

@Mike This problem is usually caused by the motor or in rare case, the power supply. We would suggest you to replace the motor, you can always return it for another part if it’s not the motor.

@ Mike Lewis. The problem you described is precisely the problem I am suffering, right down to the last detail. I’ve already ordered the motor, and hope to have it within the week. I will post as to whether it resolved the problem.


Got a Litter Robot some years ago (not from you). I started getting the problem where the bubble would rotate a few degrees on power-up and then all three lights would start blinking rapidly. So far, I have:

  • Verified that the floor sensor is working and properly adjusted.
  • Verified that the safety switch (cord) is working properly.
  • Verified that the motor is working properly.
  • Changed the circuit board.
  • Changed the complete wiring harness (including hall sensor) and verified that it is correctly wired.

When I plugged the unit back in, it seemed to cycle normally but stopped 90 degrees off-axis in the empty position (ejection ports open) with green light showing. I tried unplugging and trying again with the bubble in different positions… and always the same thing. Then I tried putting the old circuit board back in, and the “few degrees of rotation followed by all 3 lights blinking rapidly” problem came right back. OK… so I put the new circuit board back in, and the “few degrees and all 3 lights blinking rapidly” problem is persisting.

I have been through all the troubleshooting steps, replaced all of the components except the motor and the known-good floor and safety switches and am fresh out of ideas. Could the magnet in the bubble have come loose??? Or… ???

@Anthony Seems it’s a problem with the motor. If the motor turns fine with the new circuit board until it needs to go backward, there’s probably a problem with the motor, asking for too much current, which the circuit board cannot supply. We would suggest you to replace the motor based on the problem you are experiencing.

@Mathieu. You were right! Replacing the motor, which I did today, fixed the issue I described. I’ve got my Litter Robot back! Thank you again for your advice and assistance.

have only ha litter robot 2 months love it . but now will not rotate .all lights flashing .turned it off when restarted had green light,but when activated by cat motor runs nothing happens?? all lights flash? have cleaned it checked for obstructions …whats the problem?

@R.Rogers If you start the Litter-Robot and the motor doesn’t turn at all and there’s a green light, there’s a problem with the motor. If it is doing the first cycle correctly, does it work when you press the clean button on the circuit board?

thanks for your prompt response . I have turned the litter box back on, the yellow light is on, I hear the motor running the ball does not move.i took the top ball off the gear is moveing but when I touch it it stops? it feels quite loose to me…what do I need to do I just got it in November this year from amazon it is under warranty???

@RRogers The motor black cog seems to be loose. You can either tight it with an alan key or if you have purchased it with us, please contact our support center and we will proceed with the RMA.