Esptool.fatalerror: Failed to connect esp8266: Timed out waiting for packet header


I require your help regarding a problem I’m encountering.

I am making a 2WD Smartphone WiFI Car based on NodeMCU ESP8266. I followed a tutorial video I found on YouTube…
Here is the link:

Hardware concerned:
I think my hardware has no issues… I have done all wiring as deribed in the tutorial video
Software concerned:
Software uploading is the biggest problem I am currently facing … The code gets compiled in Arduino IDE software easily but when it comes to uploading it… Intitallly it shows CONNECTING
But then after a few seconds it shows me an error which is this:

esptool.fatalerror: Failed to connect esp8266: Timed out waiting for packet header.

Troubleshooting steps already taken:
I have seen some people pressing and holding the flash button while it is trying to connect. I did that but there was no luck.

Additional information:
I have connected the board using the charging cable

Thank you so much in advance for your help!

Did you already flash the NodeMCU so that it has a MAC address? I just got one to play with and have it set to just turn on /off an LED via a web page with on/off buttons.

Also, did you add “” to the Additional Boards Manager URLs of the Arduino IDE?

Here’s how to configure the IDE.

1 Like

Thanks a lot for working out on my problem… As I already mentioned, that I have tried pressing and holding the flash button but that unluckily didn’t work for me.
You said “flash the NodeMCU so that it has a MAC address”
Kindly tell me from where can I verify that my board is having a MAC address???

Secondly, you talked about that adding of URL. I have already done that

Here’s the official document:

This is what I followed:

Win32 Version Download
Win64 Version Download


OK I will try doing that… I am extremely thankful for working on my issues…Thankz again

1 Like

No worries… good luck.

1 Like

@Raahim_Irfan any luck getting the NodeMCU flashed and uploading code?

Hi there, seems like he created a new post (with a new problem) so I guess he was able to solve it :+1:

1 Like

Yes I got it solved… Special thanks to you for helping me out!

1 Like

I made a 2WD Smartphone Controlled Robotic Car. Previously there was problem uploading code to the board, which got solved…
A few new problem arose

  1. The NodeMCU board on connecting with smartphone works fine for sometime and then gradually it started disconnecting from smartphone within few seconds… The blue LED also goes off

I think this issue is because of low battery… But I am also surprised that the L298N has its red LED still on!

2)I am trying to charge my 1800mAh 18650 battery using Power Bank Charging Module… First of all please tell me is it necessary to use TP4056?

When I try to charge the battery instead of increasing it further drained itself from something around 2.90V to 0.00V
Why is it that so?
Thanks jn advance

Have you tried supplying power to the board separately instead of tapping off the same power source that’s being utilized to power the motors? Possibly disconnect from the vcc pin and utilize a USB cable to test the NodeMCU?

1 Like

Yes the issues were with power supplies… MY jumper cables either got broken OR they were loose… Thanks alot!

1 Like

I’m glad that you got it sorted out.

1 Like

Hmmm… Thanks a lot for helping me all along the way from errors to finally completing it!!!

1 Like

Hello @Raahim_Irfan , how did you solve it. I am facing the same problem and tried the steps mentioned above but couldn’t make it. Please help!!