ESCs do not stop beeping

Hi, I have been working on a drone for a while and I keep running into a problem where the ESCs continuously beep at regular intervals when I plug in my battery as you can see in the video. I carried out the arming process by pushing the left stick to the bottom right corner and the green and orange status lights turn on. However, the beeping does not stop so does this mean the ESCs have not received the arming signal or is this another issue?

WinGUI shows that there are signals being sent to the ESCs by the flight controller when we arm because the motor signal indicators move up and down with throttle inputs. However, the ESCs do not stop beeping.

Here are some more images of the wiring if it helps.

All of the ESCs have been individually calibrated.
Also, even though it appears to be a quadcopter, we have set it to bicopter as we are only using two motors at the moment.


The ESC’s beeping usually mean that they do not see a LOW signal.
This can be either that your particular ESC’s are not correctly calibrated or that they need a lower value for “Min Command”

How have you calibrated your ESC’s ?

All guides in relation to the Quadrino Nano are here:

1 Like

Hi, thank you for the quick reply. I have calibrated the ESCs individually by connecting the signal wires to the throttle channel and setting the end points of the throttle. The motors work when they are connected as individual circuits to the battery. However, when I connect the motors together to the Quadrino Nano through the PDB, the issue with the beeping arises.

Does the Throttle channel need to be showing 1000 for the ESCs to detect a min command? I can’t get the throttle channel to show 1000, as can be seen in the image, the lowest I can go is 1004. Is there a way to set the end points in WinGUI itself as I can’t set the end points any lower using the config tool which I use to change the settings for my transmitter.


The throttle channel is an Input to the Quadrino Nano, it’s not related directly the the output of the ESC’s.
In your screenshot, I can spot that your Quadrino Nano is “Not Armed” and the output to the two ESC’s are at “1000” and, if all correctly connected / calibrated, the ESC’s should not beep.

When you Arm the Quadrino Nano, the output to the motors will go to the “Min Throttle” value.

In your picture the Power Distribution Board is only used for power distribution.
I don’t see any reasons why it would change anything to the result if they are connected that way or directly to the Battery.

ESC’s will beep until they have a Low signal from the RC system (receiver or flight controller).
That’s a safety feature so they do not start spinning when you connect the battery.

1 Like

Hi, I have tried using different values for the min command and min throttle and the WinGUI shows that it is armed, but the ESCs still keep beeping.
This is what I see when the quadrino is unarmed.

After arming it, the arm button lights up:

Does the fact that the arm button lights up mean that the ESCs have also been armed or is it just that the Quadrino nano has received an arming command?


I’m pretty sure your ESC calibration is not done correctly.
Take a look at our tutorial here:

1 Like