Can't get started with LSS HT1 and Config software

Got a bunch of LSS HT1’s to try out. Also got the USB interface, downloaded and installed the Config software.

Connected power supply, USB and a single servo.

Fired-up config software, connected via the appropriate USB port.

The console indicates that it finds the servo, the ID (which is 0) and firmware version (362).

The last line reads:

INF :: Obtaining telemetry... /

Not being familiar with the software this last line feels like it wasn’t able to get the “telemetry” it was after, not sure.

After that I can’t do anything with the servo via the graphical interface on the left of the screen. All the buttons are dimmed. For example, I can’t change the ID as the tutorials demonstrate by changing the ID field and clicking “UPDATE”. Nothing works.

I can, however, change the ID by sending a command by hand using the console area. I can make the servo move as well, again via manually typed commands. I can change LED colors in the same manner. The graphical interface and telemetry area just don’t seem to work.

I tried a few servos, they all do the same.

Any thoughts on what might be going on here?



Hi Martin, we’re here to help.

“Obtaining Telemetry” means the software is sending query commands to get a continuous stream of data from the servo. This is normal. However, if the graph area is not producing a plot, we’ll investigate.

You are correct that you should be able to enter a new ID in the ID field, click “update” and the servo will restart and have the new ID. Defaults for the LSS servo are Firmware v362, Baud: 115200, LED: Off

Q1) You did not indicate which power supply you are using - can you specify? An image of the (albeit basic) setup might also help.

Q2) Which operating system are you using?

Q3) Ensuring only ONE servo is connected to the adapter, can you provide a complete screenshot of the LSS Config interface once the servo has been detected?

Q4) Can you also ensure you are using the provided serial cable (as opposed to the multi-color RC cable)?

A1 - Using this power supply:

A2 - Windows 10

A3 - Yes, only one servo plugged in to this board. Board is in USB mode. Shorting plugs are NOT connected.

A4 - Using one of these serial cables

Here’s what happens when I issue various commands manually:


>>  #0#0QAR

I get a beep/ding when I press enter.


>>  #0#0D100

Servo moves as commanded

#0QD  (issued after above move)

>> #0#0QD

No position reported


>> #0#Q

BTW, I bought several cables and servos. I tried a few of them (different cables and different servos). No difference.

I can manually change the servo ID to any number. No difference.

BTW, using Python sample code to talk to the servo I get:

Querying LSS…

---- Telemetry ----
Position (1/10 deg) = 49
Speed (rpm) = 0
Curent (mA) = 0
Voltage (mV) = 12375
Temperature (1/10 C) = 468

@martin05rc Rest assured the system should be plug and play, so the issue you are experiencing is not normal. We’ll get back to you with additional ideas, but in the meantime if you read this before our next reply, can you download the latest LSS Config software from the site? Uninstall the other one first.
When installing, ensure you authorize the software as needed (we are working on signing it).

Hi Martin,

Welcome to the RobotShop community!

I’ll go over all that was mentioned to make sure I did not miss anything.

This seems to indicate the software is able to get at least two replies from the LSS: the ID (from a #254QID) and the firmware version (from a #0QF).

As @cbenson mentioned earlier, a screenshot of the full LSS Config would be helpful here to make sure we don’t miss an important detail. You can get one with the LSS Config in focus and pressing ALT+Printscreen. Then when you write your reply here simply press CTRL+V to paste the screenshot of the software.
This is definitely unusual though.

This is quite unusual. It seems like after the initial QID/QF the software is unable to obtain more replies and the rest of the software stays locked for some reason.

This would indicate the hardware/electrical part of the LSS / power supply / adapter board are all working well and that the issue is only with the LSS Config software.

Looking forward to your screenshot(s). In the meantime, I’ll investigate possible causes and solutions.


Thanks for the feedback. I wrote s small python routine to help me change the ID’s of all of the servos we bought. I’ll probably do the same for centering and range adjustment while we figure out what the issue might be with the software. I’ll post a screen shot in a separate message (the software is running on a different computer). What I am saying is that I am working around the problem and my need for a solution isn’t urgent right now. However, I’ll help troubleshoot this just in case we discover an issue that might help others.

1 Like

Here’s the screen grab. This is a servo who’s ID I modified using python.

1 Like

Glad to hear this isn’t stopping you from useful work.
That being said, this is the first report of this kind concerning the LSS Config, so I’d like to make sure this is not more of a widespread issue and also find the cause/fix it, of course.
If possible could you try the software on a different computer just to see if you get the same results?

Thanks for the screenshot. I’ll look into it. Let me know if you have any other updates.

OK, we’ll try on a different machine. I can do Mac, Windows or Linux. For now I’ll stick to Windows.

I just tried running the software as administrator. No difference.

Here’s a screen grab showing machine details:

I looked a bit more at your screenshot and two things caught my eye:

  1. The caret control on the left is grayed out even though it is in color even when disconnected.
  2. The default servo shape without the sticker or LED color is moved upwards to the top left instead of staying in the corner where it is supposed to be.
    See the images below for details:

This leads me to believe your LSS config messes up its initialization at start-up for the left-hand side of the interface, which derails a bunch of other stuff. Why it does so it still unknown and will require a bit more digging, but I have some ideas on where to look.

I think our best course of action (since I cannot reproduce the issue locally, tried on multiple machines) will be to have you run a custom version with extra debug info. Would you mind doing so?

OK, I just tried on a different machine. World of difference. The interface came up in full color and everything was in the right place. I was able to connect to a servo, see telemetry, etc.

Thought: The prior machine, a laptop, has a screen resolution of 2560x1440. The screen is small (15 in) but high resolution. This workstation, on the other hand, has three 24 in monitors, each 1920 x 1200. The key difference in the presentation of LSS Config was that, on the laptop, it filled the screen corner-to-corner while, on the desktop, it displays as a smaller (guessing 1500 pixels wide or so) window within the desktop. Here’s a screen shot of that window on the workstation. I can’t send you a screenshot showing the full desktop due to security policies.

1 Like

I can try connecting an external 1920 x 1200 monitor to the laptop to see how the utility might behave on that canvas.

My guess is there’s some kind of a UI scaling issue that is causing the various widgets to fail to initialize correctly and the chain reaction causes functionality to degrade. How was LSS Config created? Language? Libraries? Tools? Is it open source? I’m happy to look through the source to see if I can figure this out.


1 Like

Glad to hear that.

The software initializes at a resolution of 1560x987, so your 1500 guess was quite close.
The laptop’s resolution seem like it should accommodate the software window easily but seems not too. Is it only a “hardware resolution” that is used to enhance a lower resolution that is exposed to the OS/software?
Regardless of this, the initialization should not go bonkers because of the starting window size anyway! :smiley:

It would certainly be interesting to see the results of this.

I have quite a good idea of where it is crashing. Due to the fact you are running a release software the error is most likely suppressed (improperly) and therefore cuts off the rest of the initialization. This is what would be causing the degradation of functionality.

I appreciate the offer but the software is not open source.

I’ll figure out something for you to try shortly.


Hey Martin,

I was able to reproduce the error locally, but only if the app is run maximized, which it is not by default.
Is it possible you are running the LSS Config from a shortcut that is set as “maximized”?


Here’s the screen shot of the shortcut properties as installed:

1 Like

Due to the high resolution of the small laptop display I am sure Windows is doing some scaling to avoid having microscopic text and images with applications that might not be aware of high DPI scaling. I messed with all three high DPI settings of the shortcut I am using to launch the exe. No difference to how the window is rendered.

1 Like