Wild Thumper, system sees USB but no option in Arduino port menu

I have a wild thumper.

I'm powering it with 5V 2A wall wart to battery +/-, as well as the usb plugged in and the charger power (which I realize isn't helpful).

Both a PC and a Mac recognize the USB is plugged in, making the appropriate FTDI entries in the device table.

However, I neither case do I see an option for any port in the Arduino port menu, so, of course I can't upload.

What should I be seeing as a port?

* I've been able to upload fresh 168P firmware using the appropriate instructions.

* I've tested "regular" Arduinos using this client code on both Mac and PC.

* I've tried Arduino 0023 and Arduino 1.0

The usb connector seems "firm", not loose I have an external FTDI connector, that's sort of annoying last resort to come in via D0,D1.


thanks, imrhb



To figure out which port

in Windows you just open Device Manager and then go to ports(?) to see which port the FTDI is connected. I can’t tell you for sure about the Mac.

arduino not seeing usb for wild thumper on osx - solved

thanks for the rapid responses. In my case, it appears I was either missing or had an out of date FTDI driver.  Once I installed the updated Mac OSX driver, I was able to see and upload a file to the Wild Thumper board.  I’m assuming this was also the problem on the windows machine I tried.  Interestingly, neither machine has any issue with any other Arduino board I’ve tried, but something about this board requires the latest version on my machines.

I am able to run the diagnostic and get the wheels to spin.  Next up is to see whether I can communicate with by serial, then RC.

thanks! imrhb