When connecting the Lss2MC the communication with the servos breaks down

I have a series of LSS servos (LSS-HT1) and an LSS2MC connected to the LSS-ADA board. The computer is connected to the LSS-ADA via USB-C. The switch in the board is set to the USB position and the jumpers are off.

When I connect with the servos alone (no LSS2MC) I can communicate and control them successfully. Similarly, if I connect the LSS2MC alone I can properly communicate with it. However when I plug in both the servos and the LSS2MC at the same time, the LSS2MC takes over and is the only device I can communicate with. These devices behave perfectly separately but the servos failed when plugged in the same bus as the LSS2MC

I have tried using the LSS config and it doesn’t discover any servos when the LSS2MC is connected. I have also tried communicating from a serial monitor.
I have configured the LSS2MC as specified in the wiki (D7: LOW, D14: HIGH https://wiki.lynxmotion.com/info/wiki/lynxmotion/view/servo-erector-set-system/ses-electronics/ses-modules/lss-2mc-board/) with an arduino program based on the one provided in github (https://github.com/Lynxmotion/AlternativeLSS/tree/master/examples/Lss2MC)

We would like to be able to use these two devices together in a setup as showcased in the wiki with the Dual H-Bridge (DC Motors) configuration. How can we achieve this?

Thank you very much for your help.

Hi @Presa

If I understand it right, you want the LSS-2MC to ack like a “Servo” and be able to control the motors by sending a serial command from the USB / LSS-Adapter ?

In order to do that you need to have the firmware setup in the LSS-2MC.
Install the AlternativeLSS library from the Arduino IDE Library Manager first.

Then you will have the Lss2MC example

That should make your LSS-2MC a “servo” which can be controlled by the 2MC Communication Protocol.

Let me know if you have other questions :slight_smile:

1 Like