What is wrong?! ..and what can i do!?

this_is_a_problem.jpg (72994Bytes)
this_is_a_problem_2.jpg (20186Bytes)
this_is_a_problem_3.jpg (23072Bytes)

okay.. so i just finished my new robot(8 servo quadropod)and started makeing a test program. when the test program was done i downloaded it to the picaxe and it worked! then i started to try out use the srf05 to see if it was plugged in the right way! so i made another program and tryed it and that worked too! after that test i went ahead and made a autonomus-mode program like in the ""start here" robot" when i tryed it i got the "reset error" (which i've got many times before)so i did like i use to(and it allways worked) when i reset the picaxe, only this time it didn't work! so i tried again and again and again and again etc.. after trying with no luck i wanted to make sure if something else was wrong! so i tryed to download the program to all my other robots(all 3 robots) and also tryed resetting them but it still didnt work! on none of them!!! at last i tryed to chek if it was only thet one program where was wrong. so i tried to use another downloading cable... guess what! ...it didn't work!!

please help me with this one! i dont have any idea what else can be wrong then all these i have checked

i've also attached some images


ehh... i think i just fixed it.. =D

it seems like i have one tricky female USB port..

but anyways i fixed it!!! =D