Using Sabertooth 2x12 with motor and servo


I have an RC car that i've stripped down to it's bare essentials.  It has one motor that provides forward/backward movement and it has a servo that turns the front wheels left/right.   I can use the Sabertooth 2x12 fine with the motor.  The problem is however the servo. 

The setup is as follows:  
The servo is a Redcat HX-3CP servo.  
I connect both +/- wires of servo and motor to the sabertooth's M1A/B and M2A/B respectively.
I run a wire from Sabertooth's S1 to Arduino's PWM pin 11(motor) and S2 to PWM pin 10 (servo).
And connect the ground of the sabertooth to ground of arduino.
Ground of the Servo is connected to ground of the sabertooth.
Power source is a 9.6v NiMH 2200mah battery.

The motors work fine.
However, when power is sent to the servo, it moves...but starts to smoke.   I have to quickly pull the ground wire from the servo to stop it from further damaging..

Anyone know why this might be happening here and how to fix?


thanks. for the help. i

thanks.  for the help.  i have back up HS-322 and tried that by using sabertooth to power and arduino PWM to move and that worked better.