Unable to run 4WD Meccanum DFRobot shop rover with 3.7V 1000 mah 5c LIPO


I require your help regarding a problem I’m encountering.

Description: I’ve been doing testing with the DFRobot shop meccanum rover kit and I’ve been getting a weird error recently when I’ve tried running it with a LIPO (3.7V 1000 MAH 5C) and it works for couple of seconds but then the cool blue LED’s dims and the board becomes unresponsive, I’ve tried charging it thinking it was low power but when I Have it plugged into the computer all the motors turn properly and do what they need but as soon as I have it running on the LIPO alone it cuts off after a couple seconds when the motors are running.

Hardware concerned: Kit: https://www.robotshop.com/uk/dfrobotshop-rover-20-arduino-mecanum-robot-basic.html,
LIPO: https://www.robotshop.com/uk/37v-1000mah-5c-lipo-battery-eu.html

Software concerned:

Troubleshooting steps already taken: -Charging the battery fully before running.

Additional information: I have some videos showing the behaviour but I can’t upload them since I am a new user but I am attaching a link to them on my drive to show the issues.

Working while connected to laptop: https://drive.google.com/file/d/17yLU1-lMfUlL6AaLSyZL1Jvz8rQ52cCY/view?usp=sharing

Issues when on LIPO: https://drive.google.com/file/d/17yMVhrMbXMdnYnX9RLgkar0zMA4mgSAK/view?usp=sharing

Thank you so much in advance for your help!

@Shiv_rar Welcome to the RobotShop Community. It really does seem to be a power issue in that the LiPo is either not able to provide the necessary current or is drained. Do you have any method of checking the voltage on the LiPo itself? It needs to be above 3V and anything below that might mean it has been damaged by having discharged too much.

The battery from your link should be fine (able to discharge at up to 5A, which is more than enough). it might be possible that when you received the battery it was deeply discharged and you need to put it through several charging / discharging cycles (always keeping it between 3.0V and 4.2V).

The only other issue is that operating on carpet (even if it’s short) or any other non-flat surface is a lot harder for Mecanum wheels since it adds friction, thus forcing the motors to consume higher current.

If you have the 4xAA battery holder, can you try to power the rover with that to confirm (use fresh AA batteries)? This would provide the motors with higher voltage (6V rather than 3.7V) but lower total current discharge.

Hi @cbenson, thanks for the quick response, I did some further testing and I do get some weird behaviour:

  • I’ve confirmed that the LIPO was charged (~4.2V) with the use of a voltmeter.

  • The behaviour still persists even when I’ve taken off the wheels and the shafts are spinning freely.

  • I haven’t discharged it or charged it several times since I got it so I’ll try power cycling it a couple of times to see if that helps.

  • I’ve tried it with 4xAA batteries (~5.5V I didn’t have four fresh batteries) but same behaviour.

One new thing which makes me think it’s a power draw issue is that when I had all four encoders attached to the analogue breakout pins and a PPM receiver (+ve -> 5v line from the board, signal -> pin2, -ve -> GND ) all would work individually and up to 3 of any would work but as soon as all were connected it would result in the weird behaviour and pulling out one of the encoder connection and the PPM connection would result in the intended behaviour. I have a spare 2s LIPO 1350 mah 20C arriving tomorrow with some extra connectors, I was planning to give it a try through the PWRIN ports on the expansion board to see if that solved the issues.

I was unable to find any documentation for the 2A expansion board that was shipped with the kit but 'm assuming that I can power the system through that port instead of the mini jst?

The documentation for the shield can be found here:

Some (general) questions

  1. Can you double-check the jumpers on the shield are set correctly to use Vin

  2. Check that the motors themselves can spin freely and there’s not an issue with the gears or meshing (they pop out of the plastic case fairly easily but gently pulling the plastic to the side). This will also remove all torque on the motors.

  3. Check the On/Off switch on the rover PCB is OK, and set to ON correctly.

  4. Which test code are you using? For a tracked rover or for the mecanum? Note that the mecanum test code needs input from a computer.

  5. Note that a 2S LiPo might provde 8.4V, which is quite a bit above what the small Tamiya motors are rated for. We’ve never tested them with such a high voltage to know if there will be issues. We normally suggest swapping the motors for ones which are rated higher:

  6. Can you power the PPM receiver from a different source? The onboard regulators can only provide so much current, and like you said, using a 3.7V battery, small regulators etc. might be the issue. A fix might be changing to the 6V motors (link above) and using a 2S LiPo.

Regarding connecting the battery to the shield’s Vin rather than the Rover’s JST terminal, the power is shaved via the Vin pin, therefore so long as you don’t have a second power source which conflicts, you should be OK.

1 Like

Some further updates:

  • I’ve confirmed that the shield jumpers are set to use Vin

  • All motors spin without issue with no other components connected (no encoders or PPM RX) so the ON switch on the PCB looks/feels ok.

  • I’m using this code I wrote: (https://github.com/shivrar/4w_rover/blob/main/main_rover/src/main.cpp) which uses FreeRTOS but to test right now it just turns turns all the motors one direction and then flips it after a certain time.

  • Thanks for pointing out the voltage for the motors, I’m swapping them out for 6V ones when the new LIPO reaches.

  • I’ll try to power it separately but since I am already getting the new LIPO and motors I figure I’ll just hold off untl the new hardware arrives.

  • Something I forgot to mention which may or may not be a related issue, if I have the L1_SEL jumper on the motors work with nothing else connected but when I have the PPM rx connected it cuts off again.

I’m also getting some resistors so I’ll try hooking that up to see if it helps with the current draw issue. I’ll keep you updated and many thanks for the help :slight_smile:

Without looking at the code itself, can you check the manual to try a “full speed” test on all four motors? It sounds like the electronics are working correctly, so trying to help pinpoint the issue with the current / voltage.

The DFRobotShop Rover Mecanum platform is about as bare-bones and inexpensive as it can be, and has worked for many, many years. We’re here to ensure you get it up and running so you can keep experimenting.

Once again - careful about running it on carpet as those Mecanum wheels really only work well on flat surfaces.

1 Like

Hi @cbenson,

Sorry for the late update been a bit busy, so some updates, I tried the 2s lipo and surprisingly nothing turns out, I followed the tutorial from https://wiki.dfrobot.com/2A_Motor_Shield_For_Arduino_Twin___SKU_DRI0017_ , testing it with both Controller board and an UNO I have on hand and neither seem to even come on, I also tried it with the 1S lipo (via the same PWRIN port on the shield) in both cases and still nothing. I’ve confirmed that both UNO and DFShop controller boards are fine, both LIPO’s are nominally charged (~4.0V for each cell, confirmed by a LIPO tester/checker). The more I test the more I get the feeling there is an issue with my shield.

Edit: Having both jumpers on PWRIN wasn’t working so I jumped one across VIN->PWRIN and the board is getting power and all motors are spinning. I’ll try everything tomorrow to see if the power draw issues are solved.

Ok, await your update. Given that your testing involves no load on the motors, it’s a bit of a head scratcher. We’re not aware of any design changes to the shield (we’re a reseller rather than manufacturer for that aspect, just like the Tamiya gearboxes) and the Vin jumpers seem to still be able to draw power from the Vin pin. Normally when a motor controller chip is defective, the results are fairly evident (one channel doesn’t work, works only in one direction or exhibits very odd behavior).

One test might be to change the jumpers to PWRIN and use two batteries (again, just for testing) to see if there’s an effect.

Although it may be unrelated, when DC motors are set to rotate at very slow rpm, they lose considerable torque, which is why the suggestion was made for the full speed test.

Just noticed in the video “Issues when on LiPo”, the front left wheel doesn’t rotate at all. Is there something blocking it? Perhaps triple check that the gearbox was assembled correctly?

@cbenson Huzzah, good news. So it was definitely a current draw issue from just using the 1S LIPO. For reasons I am still unsure of why, the 1S couldn’t handle the draw of all the additional electronics but with the 2S everything runs smoothly (4x6V Brushed DC motors, 4 encoders, 1 PPM receiver, and an additional IMU device). One thing I should be mention was the site for the expansion board can be slight misleading. The PWRIN jumpers to VIN, on the tutorial site showed both jumpers parallel to each other on the same pins but a quick check with a voltmeter for continuity shows that the VIN is not connected and doesn’t power the controller board. To keep the parallel lines to provide more current I soldered a quick jumper to connect all the parallel lines and everything seems to work now :slight_smile:. Many thanks for the help on this

Excellent news. Enjoy!