Unable to control RMD-X6 with CAN-BUS Shield

Hi Guys (First ever post, sorry if I messed anything up here)
I would really appreciate any help as I’ve almost given up and thrown away hundreds of euros :frowning: I’ve tried everything to get the Adduino + CAN-BUS Shield + RMD-X6 to work.

I can control the motor using the USB UART and the MyActuator software.

What I’ve tried so far …

  1. Added 2, 120 Ohm Resistors on each end of the cable.
  2. Tried removing one as I read there is a built in one on the motor side.
  3. I changed CAN_1000KBPS to CAN_500KBPS,
  4. I tried every ID (7,8,9,10,11,…).
  5. I got two shields, a Sparkfun Electronics CAN-BUS Shield and a Seeed Studio Shield.
  6. I tried using the newer mcp_can.h library and older one.
  7. I must have tried several examples.

I bought two of these motors, the RMD-X6 1:6 And the RMD-X6 S2 1:35.

I wrote several emails to MyActuator but no response.

The below code initiates fine but prints out “error” at the end of the code. I guess
CAN_MSGAVAIL is never equal to CAN.checkReceive().

I hoping obi wan kenobi isn’t my only hope, can you help ?

Hello @DeclanDublin and welcome to the forum,

Do you know which series of motors you have?

If they are V1 maybe this could work for you:

You mentioned a code but you forgot to share it, could you please share a link or paste the code here? As well as the exact error you get.

Regards

1 Like

Hi Geraldine

O, wasn’t finished typing before it posted :slight_smile: First, thank you so very very much for helping me, I’m not actually sure what version I have, I see on the back “SN 10222000203” but can’t find anything on this number. I downloaded the library, still trying to get it to move. I’m now thinking that my code, everything was based on the V3, I’m sure I don’t have this version, I bought it not long ago on the RobotShop site, it don’t mention driver versions anywhere, would be sad if they are selling old versions of the motor. Again thank you, any and all help no matter what is so appreciated.

I believe those motors are V2, they should work with the V3 protocol.

Have you tried using the debugging software?

Hi …
It works with the 2.1 tool via the UART, I just get an hour glass if I try use the V3 tool.

Does this mean I have the V2 motors (Drivers) ? I’m lost. :slight_smile:

Are your motors like the ones listed here?

If that’s the case then they should work with the V3 software.

Perhaps this can help you:
https://www.myactuator.com/dowload

Hi Geraldine
Yes, they look a little like them, I see they are SN : 10222000207, while mine is SN : 10222000203. Mire also have the CAN_L, CAN_H connector and not the solider type.

Motor 1. RDM-x6 1:6 (SN:10222000203) (MC300A) I’m thinking its the older one
Motor 2. RMD-x6-S2 1:36 (SN:10222000403) I’m also thinking this is an older model as I see a newer one with V2 written on the back

I contacted the MyActuator people and was given a document with commands. I tried everything, enabling the motor with 0x88, but nothing worked.
I verified the CAN-BUS shield was sending correctly by setting up a second Adruino board and CAN-BUS shield, one sending and one receiving, this worked.

I was told to look at an ODrive, I know nothing about these, I’m now doing research.

Thanks again for your suggestions and help, greatly appreciated.
Declan

1 Like

My last post for future victims of this company (MyActuator). I got a Seeed Studio USB-CAN Analyzer. The driver on the motor is basically junk, doesn’t work, I guess that’s why they brought out a V3 of the driver, I would not buy these motors.

Unfortunately, I have to agree!
MyActuator have failed to respond to any support queries over the last few months - and now their website just goes to a holding page.

The V3 Config sotware doesn’t work for V2 Motors. Although the CAN interface appears to work - you can request & receive data, none of the motor movement commands appear to work properly. The data received via CAN, in some cases disagrees with the data on the config software - which can drive the motor OK.

I wonder if anyone has documentation for the Serial UART iinterface? If CAN doesn’t work, there is potential for controlling them via serial.

There seem to be several versions of the CAN protocol out there with different PID’s for some of the commands. It feels a bit of a mess.

I’ve also noticed that the myactuator website is down. Does anyone know if they are still in business?

Thanks,
-Scott