Turtlebot 4 Navigation/RViz issues


I require your help regarding a problem I’m encountering.

I am a high school student. Attempting to get navigation working on the Turtlebot 4 but I am experiencing an issue getting the TF data up on RViz. when attempting to run the Nav2 bring up command on the Turtlebot and the RViz software on the PC I either get Frame [base_link] not found or no map found. When running just the RViz software with nothing else running the robot has a No TF data error. I am following the instructions on this site (Rviz2 · User Manual).

Hardware concerned:
Software concerned:
Ros2 galactic
Troubleshooting steps already taken:
I have tried both nav commands described manual
Additional information:
Thank you so much in advance for your help!

Hello @ebear112 and welcome to the forum,

Have you tried this tutorial?

Are you using the latest code?

The issue might be caused by the TF remappings

Or perhaps it could be related to this:

Either way, it would be best if you create an issue on Github:


Thank you for the response! Unfortunately, I did try following all of those guides and my remote PC is detecting all the create3 topics. I will post my issue over to their GitHub and see what they can do. Thank you for pointing me in the right direction!

1 Like

For anyone else having this issue, I narrowed it down to our Create 3 losing connection with the pi.