Ssc32u board not working

Hello I have the ssc32u board and the bot board
Just to test the ssc32u board I connected a 6v battery to it and got no power but when I connected which seems like a good servo to it the board lit up like a christmas tree.
I then connected another servo to it it did not do anything.I tested both servos and one did not move the other one did move so I connected that servo to the ssc32u. Board and got nothing no lights no power. I got a new ssc32u board connected a 6v battery to it and it lit up no seevo was connected is there a short somewhere?

Thank you dan digregorio

Can you provide a few clear photos of your setup? As before, please get the SSC-32U working on its own first (Sequencer software for example).
To get it working with the computer:

  1. Screw the wiring harness to VS1, ensuring red to positive (+), black to GND (-)
  2. Connect an RC servo to the three pin header of your choice, for example the first one is 0. Ensure the yellow signal wire is connected to the row associated with pulses, and the black wire as part of the connector goes to GND.
  3. Connect the SSC-32U via USB to your computer’s USB port
  4. Go to Device Manager and verify the device installed properly (update the FTDI VCP drivers if there are any issues)
  5. Download and install the SSC-32 Sequencer and run it
  6. Select the appropriate COM port at the bottom right, and the baud rate should be 9600
  7. Move the slider and the servo should move (assuming you flipped the On/Off switch to ON).

When connecting to the BotBoarduino:

  • Connect the Tx from the BotBoarduino to the Rx on the SSC-32U
  • Connect the Rx from the BotBoarduino to the Tx on the SSC-32U
  • Connect one of the GND pins on the BotBoarduino to the GND pin on the SSC-32U.

NOTE: The BotBoarduino does absolutely nothing if no appropriate code has been uploaded to it which sends commands to the SSC-32U. If nothing is happening, you need to understand what the code is / does and how to initiate motion (for example, is the BotBoarduino waiting for input from the computer keyboard?)

1 Like

hello again here is some pictures showing how I connected the ssc32u board .

I connected per instructions you provided the first picture shows the 6v battery connected to VS1 and no power at all. The second picture is a bad servo connected to the board. I get power to the board
The 3rd picture is with a good servo connected to the board I get nothing no power but the servo moved a little. 4th picture is with the ssc32u board connected to a USB port and to the computer and the running lynx term typed the ver command and got no response back but the 5th picture I connected the bad servo to the ssc32u board and got the version ssc32-v2.50usb.

also connected the good servo with everything connected to the computer got nothing. That is the best I can do

Your electrical setup looks good. We see you’re using the old Lynxterm software as opposed to the SSC-32 Sequencer:

Lynxterm requires that you Setup the communication as well by pressing the Setup button, then selecting the right Port and Baud rate (9600). Once done, you need to press Connect, then you can move the sliders associated with channel 0.

In the Sequencer software, you should manually select the right COM port and baud rate (9600).

Just in case there was something different about the servos, I searched “Sainsmart SR317” and there’s almost nothing online aside from them being used in a discontinued hexapod.

Hello again I have tried every thing from the lynx term to the sequencer and i get nothing i have tried a 996 type servo good and did not get nothing no lights but a little movement the one which i tested with a servo tester will not move the servo rested a good servo and the servo moves. Connected that to the ssc32u board and still got nothing connected the bad servo to the board the board worked got the ver command to show the version so I am still thinking the board has a bad resistor or capacitor or some thing.because my new ssc32u board works with out
Connecting a servo to it.

Our apologies for the longer troubleshooting as it is incredibly rare these boards are actually defective. We’ll transfer this to an internal ticket where our RMA department will request your order number. In the meantime, if another SSC-32U board works with the same electrical connections and the same software and USB port, then indeed, the issue is either the baud rate or something is wrong with the board.

This topic was transferred to internal RobotShop Support.

Hello I am writing to inform you that the ssc32u board was bought a while ago it worked fine with phoenix code but
I must have done something to it. but I tested it out by jumping the pulse and vs1 pin where you connect the servos and
it lite up and worked even with the lynx term and sequencer program but also jumped the vs and the VL pins
the green junction box and it lite up. So on my part I will go further and meter the board to find the problem
I have new boards the bot board and the ssc32u. I will use them for my spider robot which works great with the phoenix
code. What I need help on is routing the servo wires on the spider robot. But that will be some other time.

Thank You for all your help I will be back on this site to check for more help with problems.
I recommend any one to come to this site here you will find solutions to problem like mine

Thank You
Dan DiGregorio