Ssc32u and botboarduino

ssc32u and bot board
hello I have the ssc32u and bot board for my 18 dof heapod robot

testing the boards out, I connected both together using a 6v battery pack.I then connected a I thought was a good servo
both boards lit up lynxterm sees the boards I get the ver number which is good so far so I tryed another
servo I get nothing.The first servo I tested with a servo tester no movement from the servo.I get a red light
but when I tested another servo I get movement which is telling me that servo is good.
Could there be a short somewhere?

@dandigregotio Unfortunately Lynxterm cannot be used with that setup - you would need to connect the SSC-32U directly to the computer. The BotBoarduino is a programmable microcontroller and as such is not programmed to understand the commands / communication being sent to it by the interface.

Note too that you only need to connect VS1 on the SSC-32U, and connect VS1 using a set of wires to VL on the BotBoarduino (one battery solution).

Can’t quite tell, but do you have The Tx from the SSC-32U (yellow) connected to the center pin (voltage) on the BotBoarduino? The Tx and Rx pins from the SSC-32U need to be connected to signals on the BotBoarduino. If one of them is connected to voltage then yes, there is a problem.

1 Like

Thank you for getting back to me .
Here are better pictures. I tried it again and connecting a good servo to the board it does nothing. but connecting a bad servo to the board the both boards light up. I followed the instruction book on how to connect the both boards together but like I was saying the good servo the boards do nothing but I get a little movement but the bad servo I get no movement

I do have the yellow wire connected to the center pin. I can not see how a bad servo makes everything work and a good servo does nothing but a little movement.

You have the Tx pin from the SSC-32U going to the BotBoarduino’s 5V pin (which is being powered at 5V based on the jumper) which is really not good (yellow wire). That wire needs to be moved to another “pulse” pin (same row as the red wire).

Can you separate the SSC-32U from the BotBoarduino, power ONLY the VS line on the SSC-32U and connect it to the computer and operate via Lynxterm? That will help eliminate any uncertainties with that board.

The Botboarduino is more difficult to troubleshoot because you need a sketch loaded on it. What sketch were you using before? Can you provide a link?

1 Like

Thank you for getting back to me I will look at it and change the connection.that could be my problem.I had it all connected to my 18 dof hexapod spider robot and using the pheonix code program it was working fine but I wanted to fix the wires and make it look clean so I took it apart
Thinking I shorted the both boards out or one because i tested the boards and got no power but I checked the jumper to the xt and usb pins and the jumper was making no contact with the pins so i replaced it with a new jumper.
It worked. But then I did not know the servo was a bad one which let me think it was causing a short.