SSC32 not connecting


I bought an SSC32 because I wanted to try to build a hexapod.
I use Win 10 and I could not get the board to do anything. I managed somehow to connect to it but only selecting COM port and baud rate 9600, and even so the servos did not do anything.

In device manager it appeared like this:
I was looking through the forum and found this topic

So i tried to change the PID ID… now it doesn’t work at all!!!
the FT_PROG can’t find the board anymore!
in Device manager now it shows up under “other devices” like this:
I tried to install the driver from the product site but nothing changed

Any idea is welcome!

1 Like

To confirm, you have an SSC-32U (as opposed to the older SSC-32)?

Did you try to connect it to the Sequencer?

It uses an FTDI Virtual Com Port (VCP) chip, not the one you have above. Normally Windows automatically detects and downloads the correct driverts.

You should not able to change the PID settings on the board, nor the ID.

More about the SSC-32U here:

You need to ensure the program (ex. Sequencer or other program) communicating with the SSC-32U is set to the same baud rate as the SSC-32U itself (check the button and the light pattern as described in the guide above).

1 Like


I have an SSC-32U model. Bought it from the german robotshop site.
I do not know how it allowed me to edit with FT_Prog…but it did…and since then I do not have any connection.
FT_prog says no devices connected.
I downloaded the drivers from the FTDI page and tried to add them manually but the board still stay unknown:
Here is how i see it in device manager:
Regarding the baud rate I did try to edit in the device manager (when it used to see it normally) to 110000 but it still did not connect in Lynxmotion, only on 9600.

OK, so installing the driver traditionally did not help.
I even disabled driver siganture check on windows.
What I managed to do is install the FTDI driver from the vendor with the executable file and the go to Update driver → Select from a list , and selected FTDI from there.
Now I can see it in the device manager as USB device but still nothing.

I’v set the baudrate manually:

I’v then tried the LynX Terminal. It looks like it connects but does nothing. Upon asking for firmware it does not show anything

So if you have any other tips…

Thank you!

We’ll see if we can proceed with an exchange. Note that for the replacement, don’t update the firmware or anything. Connect ONLY the board to the computer via USB cable at first.

1 Like