SSC-32U servo controller board win7 issue solved

Having just recieved my ‘Lynxmotion AL5D PLTW Robotic Arm’ I found that the ‘SSC-32U servo controller board’ did not work via the USB, using the ‘FlowArm PLTW’ software.

Being a retired computer engineer, I did some reserch and found that the ‘usb’ on the SSC-32U servo controller board’ requires the windows usb driver to be the ‘FT232R USB UART’ Driver.

Here is the download link to the driver.

and the install instuctions:

It maybe a good idea to have these links on the product page. Just for us old farts who still use win7.

All the best


The FTDI Virtual COM Port drivers (for various operating systems) on the manufacturer’s official page:
The link is on page 20 of SSC-32U the user guide:

Page 45 of the AL5D-PLTW guide:

If there’s a manual where we missed adding the link, we’ll certainly add it.

Normally Windows 7 would detect the FTDI chip and install the driver automatically. Not sure why it did not detect and install the drivers automatically in your case.

Hope you enjoy the arm!

1 Like

It did detect the board but the generic windows driver didn’t work.

Maybe because I use bare win7 and don’t let it upload any win updates as the win updates often stop my software from working.

Could just be a quirk on my pc…

also I purchased the assembled robot and guess that I neglected to read the manual…lol

anyway it all works now and I have to say that its a great product and very well made.

thanks for replying