[ SOLVED ] Crystal oscillator for PIC

Hello folks, I'm having lot of problems with a PIC16F876A.

When I powered my newly built robot for the first time, the first thing I checked with my oscilloscope was the clock source, and found out that the crystal was not oscillating. Then I put my pic on the breadboard and started testing.

My results are that if I put a capacitor ( tried both 22 and 33pf as on 16f876A datasheet ) between OSC1 and ground, there isn't any oscillation on both OSC! and OSC2 pins; if capacitors are both from the two pins to ground as the original datasheet schematics, there is still no oscillation at all. Finally, with no capacitor there is my pretty 16MHz, attenuated if a capacitor is put between OSC2 and gnd only ( signal on pin OSC2 only ).

Should I run without capacitors?



What I exactly did:

  1. Long time before, I set up on the breadboard a simple circuit, fully functioning. The circuit was the same on the datasheet with 33pF capacitors.
  2. Now I made a perfboard with all my robot logics, made my former testings on sensors and so on and then put on my pic when I was good to go.
  3. Then I saw on my scope there was no oscillation. I tried an other pic I had used before but nothing.
  4. So I set up the bradboard again and I'm getting all the weird stuff described above, even with a newly bought pic.



What have I to do?

P.S. Also corrections to my English are accepted ;-)

I’ll keep this post even if

I’ll keep this post even if my problem have been solved.

Remember, when probing so sensitive circuits put your oscilloscope probe to x10 or it will interfere!

Stupid question

You were actually using a crystal and not a resonator, right?

I’m sure it’s a crystal…

I’m sure it’s a crystal… or have they the same package?

But now it’s all solved, it was just the oscilloscope probe.