Problems with my "Start Here" robot *Solved

DSCN2277.JPG (1709309Bytes)
Screen_shot_2010-05-26_at_9.19.27_PM.png (238709Bytes)


For some reason (that I've spent hours trying to figure out) my computer says "Hardware not found" on my picaxe 28x1 board (Everything looks exactly the same as the one on the Start Here page except i used individual resistors instead of the DIL chip) My board is definitely getting power as the servo turns everytime i insert the batteries or replug in the servo cable into my board, I also have all the drivers installed on my mac (and my windows computer which has the exact same error) the compiler installed, MacAxepad Installed (WinAxepad on my windows) Macaxepad customized to know what picaxe board it is and the port number (COM on windows computer) my computer recognizes that my Axe027 Serial Cable is plugged in, but it wont recognize my microcontroller, I've supplied images of my setup.


which chip?

You need to select the chip you are using. In the case of the start-here bot its the 28X1. 

In the picture on the window underneath the error, I cannot see a selected radio button next to 28X1 / 40x1. 

A picture is worth a 1000 words…

…and I could not have solved your problem if you had not incuded it!

Your 28x chip is plugged in upside down. The little notch in the end goes the other way.

Good eye Chris!

had to zoom in too see it.

It Works!!!

I’ve taken that chip out a bunch of times, i must have accidentally plugged it in wrong, but now it works!!! Thanks!!! I was all prepared to buy another project board if i had too, in fact, i already bought another microcontroller :slight_smile:


Since it wasn’t working i actually tried every option, I accidentally left it on that when i took the screenshot.

Coding Problems…

Ok, so i can program my robot now, but for some reason, whenever i use Frits’s “Start Here” Wall Avoider Code (and change the code a little as high 4 low 5 turns my left wheel backwards) my servo looks in both directions (like it should) goes too the middle, then it just turns without moving forward when there is nothing there and when there is something there it still turns in the same direction it does when there is nothing there (no matter where the object is) Im guessing this is a problem with my IR sensor, I connected my IR Sensor with female-female headers, could that have something to do with it?