Problems with I2C -- DISCARDED

I'm trying to control two motors  by means of a joystick. This means I've coupled the potentiometers inside the joystick to my Picaxe 28X1 and my Picaxe 28X1 to two MD03 motor controllers. 

While testing I'm using only one potentiometer and one MD03. The problem is that I cannot get the system to work.

The program I'm using right now is:

i2cslave %10110000, i2cfast,i2cbyte


readadc 0,b0

gosub i2c

goto main


writei2c 3,(b0)

writei2c 0,("1")



I've tried to use 0xB0 as address, as well as i2cslow as speed...

Please help? It's kinda urgent, since it's for school...

Anyway, thanks!


PS: sorry for my English in the vid!



EDIT: I've found out that the motor controller was broken, I'll try again, until then you can ignore this page ;)

Yup, slow it down

It is such a short, effecient code, it is probably looping too fast and dumping too much data to the motor driver. I have had this problem with my eeproms and I2c servo driver.

Add a few pauses here and there and see what happens.

–Your English is perfect.


I should add…

I just looked at the data sheet and it seems this can do a lot of stuff via i2c and I am happy to get you going with that but if you are in a pinch, you can control the motordriver via PWM, or servo control if you want --Might get you going faster.

Skype: lmrhelp

tried it

first off, I have to use i2c, that’s kind of the assignment :wink:

second, I’ve tried to add ‘pause 30’ after each i2cwrite-command,  both with %10110000 and 0xB0 as address and both with i2cfast and i2cslow as speeds… neither did work


an other ideas?


– about the English: I meant that I was sorry for the ‘eeeeerrm’ uses :wink: