Problems with Arduino XBee Shields

Hello All,

I've recently bought two Arduino Xbee Shields and I can't  make them work.
I've tried this example ( and also this from Guibot ( but they haven't worked...
I've also tried the Gareth's walktrough (, the X-CTU detects both XBee's, the type and the firmware but on the "Range test" all I get are errors...


Can anyone help me?

Yes, I had the same problem,

Yes, I had the same problem, with two Xbee shields and two Arduinos.

Guibot example is great. However he forget to mention one thing. His code use a baud rate of 19200, for this code to work you must reconfigure the baud rate on your Xbee and the PC setting to 19200 or just change baud rate on Guibot code to 9600 (Xbees come out of the box with a baud rate of 9600).

NOTE: When programming your Arduino board make sure to remove the shield first and if you whant to change any of the setting on your Xbee take out the Arduino chip then put back the shield.


I’ve tried both ways you

I’ve tried both ways you described but no one of them have worked.