Problem with SparkFun PicAxe USB programmer cable

Ok, got to the point where it's time to start coding and I got power to everything that needed it and started installing the drivers needed for the Picaxe programmer cable. Well to no avail. If anybody has an idea a walkthrough it would be appreciated.



OK… Can we get some more details?

What are you using, PC or Mac? What have you loaded? What error(s) are you getting?

The PICAXE manual ‘Getting Started’ gives a walkthrough on how to install, etc, did you follow that? If not, please reference that and let us know what step you are failing on.

All the manuals are located here:

Hope this helps.

Sorry about the lack of info

Guess I’m guilty of what everybody else is too -oopsie-

My system runs on windows vista

Where it fails at is when you hit the test button after you get everything set up. I’ve been the step by step a few times, trying different ports to no avail.

I’m trying to hook up a Picaxe 14M to the programmer.

USB Program Cable

I saw this post on the Picaxe Forum and thought I would pass it along:

"I say this, because if you disconnect the AXE027 cable from the PC and restart the Programming Editor (and think also applies if you already have it running and disconnect) then the PE cannot find the AXE027 and by my experience reverts to COM 1.
In summary, it is okay to disconnect and reconnect from the PICAXE but seems that the AXE027 cable must be connected before starting the programming editor and left connected to the PC while the PE is running."

The AXE027 cable and your Sparkfun cable may act the same.


vista no bueno
your problem is probably vista …

Did some testing…

Well, I hooked it up again and this time checked everything from start to finish. The usb port and usb cable both work like they are supposed to. The audio cable works. I plugged in the programmer, heard the beep that the laptop makes when a new usb port starts up, booted the PicAxe Programming Editor, set up the port according to the instructions, hooked up DMM, started up the test part of the editor, took measurements, 2.7V on the output and 0.0V on the input. hit the test button on the editor, took a measurement on the DMM(the measuring thingy) and there was no change. I’ve tried this on several ports on my laptop and still nada. The lights on the programmer stay lit even if a chip isn’t hooked up the programmer.

I am thinking that it’s broken, any ideas or suggestions are welcome.


Mech Out

Well got the new cable in today

Got the new PicAxe USB programmer in today, and yes I had fun playing with the 8M protoboard it came with. Not sure what I’d use an 8M for besides a servo controller and maybe sensors that required overhead but didn’t need real time processing. Though it did give me an idea for some other things I’m working on. Will have to troubleshoot the drive board, it doesn’t want to program in it but will off of the board. I may make a dev board for the 14M that has socket and some headers, just an idea.

Mech Out

Solution to the SparkFun USB Picaxe programmer not working.

I had the same problem as MechGeek2000. Also got the unchanging 2.7V on the input pin when using the PE test program.

- Switch the TX & RX leads from the programmer to the chip. I also uninstalled and reinstalled drivers as noted below but I don’t think that was it.

For reference here’s my final setup:
Windows XP SP3
PE 5.2.9
FTDI (22 Oct 2009)
- Windows XP drivers from this page VCP and D2XX drivers are bundled together for Windows as a combined driver model (CDM).
- I first uninstalled all FTDI drivers using the CDM Uninstaller from here
- Then installed new drivers choosing the windows option to install from a location rather than using the setup exe. (Don’t think that matters)
- Blinky lights on the Sparkfun adaptor just stay solidly lit not matter what happens. Perhaps this is due to the small O8M program I downloaded.
- COM7 used. (Don’t think that matters)
- Voltage in input pin of chip is 0V with PE test light button off, 3.2V with test light button on.

My original dumb question was at

**Double that. **

Double that.


was this problem fixed - or just ignored?

Kim, I see you solved your problem, but I’m not sure that the problem is the same for me.


I have a sparkfun programmer adaptor, brand new, and I really can’t get past the “verification error” stage.

I’m using a mac, Have the drivers installed and I’m using macpad. the serin/serout text loop works just fine for me. i.e. I can send and receive in the terminal. Change the test status from high to low - and nothing changes on the serout voltage relative to G - even disconnecting.


I think that simply buying one of the axe28 cables does not solve the problem at all - just pushes it away. My point of getting the sparkfun board was to save dollars…!!

anyhow, it’s nice to know that it’s not me screwing up my components for once…or is it? hmm.


Here’s my results with the

Here’s my results with the sparkfun picaxe programmer when running the ‘Test Port’ test from the program editor.

Using WinXP.

1) Connect the download cable (and USB adapter if required) to the computer.

  - using the sparkfun pixaxe programmer connected to 28x1 chip via picaxe breadboard adaptor.

2) Make sure the PICAXE chip is inserted and powered (4.5 to 5V).

 - powered up and getting 5.1V (using 4 x AA NiMH)

3) Use a multimeter on the DC Volts setting to measure the voltage between the PICAXE serial input pin and 0V.

- getting 0V

4) When the LED is off, the signal should be between 0V and -1V.

 - reading 0V

5) When you click on the LED the signal should switch hi

 - LED button clicked on. Getting +3.1V at serial in pin 6 on 28x1

Note: The TX,RX indicator LEDs on the programmer are always fully on. They don’t flicker or anything. I’ve also tested a Picaxe08M chip and that works fine. Not sure of the voltages though.