Problem configuration MicroController Multiwii SE V2.6


I require your help regarding a problem I’m encountering.

I just bought a flight controller do make my own drone.

I choosed the MWC Multiwii SE V2.6 (from Amazon :

The issue is that I downloaded the MultiWii and Arduino and when I tried to upload the software on the board it’s very long and at the end I encounter an error… I can see that the FTDI flashes so something is been pushed on the card but it just don’t works.

The FTDI I use is this one and I’m doing the manipulation on my computer (Windows 10).

Do you have any idea what I can do to make it work?

Thank you so much in advance for your help!

Since you did not provide the error here, have you tried to look up the error on the Arduino site?
Make sure you select the right COM port and board type.
You also need to ensure your pins from the adapter connect to the correct pins on the controller
Not all FTDI chips are genuine either.

For more support, you’ll have to provide the error you see, perhaps a few clear photos of your setup (so we can double check the pins are correct), how the board is powered etc. You also need to indicate what changes you made in the code in order to use that board. These flight controllers are rarely “plug and play”.

Have you also reached out to the manufacturer of that flight controller?