PIcaxe 28x1/motor ? help/problem

you guys might have seen my post over here:


i got help on my first question, but this is my second one:

i have soldered the 2 wires to the board and hooked them up to a motor. i have tried the different setups (high/low 2/3/4/5/6/7 in the programming editor) number that frits| described in the "start". any1 got any ideas?

i have now got the pic up.


Got a picture of what you’ve
Got a picture of what you’ve put together? It would help to know where the motor is soldered. I also don’t understand what the “differetn setups” followed by numbers means.

oh yeah, sorry
i will update the post so there should be a pic and better description.

Do you have the motor driver

Do you have the motor driver chip in place in the right spot and in the right direction?

What stuff are you using? Are you using the l293d (not sure exact numbers) motor driver chip? If so are you wiring the the motor wires to A on the board or B on the board? Is the l293d installed correctly? Are you using commands like low 3 high 4 or high 5 low 6? try these things

yeah, im pretty sure but…

im using a “suitable” replacement- or so sparkfun says-because i didn’t feel like shipping from wherever-somewhere over the mountains.

i forget what it is called and i’ll try again…

btw-thanks for replying.

how do you have so much patience? ive gotta learn it from you…

How about another picture

See if you can take a picture that shows the connections made on the motor A/B side of the board, including the secondary power connector/jumper.

It would also be useful if the image was a bit sharper and it wasn’t mirrored (how did you do that?)


okay, didn’t really get a lot of info out of your post, so let’s start at the top:

  1. Programmer works? Chip gets power, etc?
  2. Motor works by itself? Connect it right to your battery to test.
  3. Correct chip? The board is made for a l239, but the TI SN754410 should work (according to SparkFun, anyway).Minimum supply voltage is 4.5, so you’ll need 4 AAs to get that.
  4. Chip is pointing the same direction as the picaxe chip?
  5. Solder. Solid connection?
  6. Your code: These are the only combinations that you will need:

“low 4: high 5” and/or “low 6: high 7”

The driver needs a combination of 1 low, 1 high to power the motor. high/high and low/low won’t do anything. Which pins should be high/low is up to you, but 4/5 is one motor and 6/7 is the other.

6. Your motor is bi-directional, right? If not, you can use a single outpin through the darlington driver.

7. A tip for pictures: If you have a digital camera, take the picture zoomed-out (so the camera can focus) and then enlarge it on your computer before you upload.

Good luck with your bot! Don’t give up!



1. Yes, i am pretty sure it gets power because it connects to the "hardware"

2. Yes, the motor works.

3. I have the "SNblahblah" (any1 no if it works?).

4. not sure, i have tried the chip both ways, neither worked.

5. Pretty sure the solder connection is solid.

6a. I have tried both, to no success.

6b. what do you mean by "single outpin"?

7. Thnx for the tip!!!


im really sorry to bother you, but i am such a n00b.




Don’t worry about it. Everyone’s gotta start somewhere. I myself am only slightly less of a n00b myself, but I’ve been where you’re at, so I feel your pain.

by “single outpin” I mean that you can connect your motor to a single digital output on the board to power it. ONE WAY ONLY, though. To do that, put in the UNblahblah chip that comes with the board, connect the red motor lead to a V pin, and the black lead to the digital out. Program “high 0” or whatever output and try that. But that only works if you’re not using reverse …


thnx… i’ll try that


Patience is the key to true
Patience is the key to true happiness grasshoppah. Actually I deal with looking at server issues all day long. I’m used to troubleshooting one step at a time. And of course 99% of them are due to a “stupid” error that should have been caught right away. My favorite was troubleshooting a network issue for 5 hours because the tech put the ethernet connection into socket 2 and not 1. Had I walked around to the back of the cabinet I would have seen it in 20 seconds.