PICAXE 28X1/Cable problems,


I'm new here and I really like this site, everyone is nice and helpful. I bought a PICAXE 28X1 starter kit, some motors/wheels and the motor controller and a few other things on my small budget. I thought I had everything but...no serial programming cable. I decided to make my own because I dont wanna wait 2 weeks for it, pinned it out and everything, ground on the db9 goes to gnd on the 28X1, TX goes to serial out but i cant get serial in to ring-out(the furthest i can trace it is to the 10k and 22k resistors). When I connect to my COM1 port and try to PICAXE>Run or F5 I get a error window telling me it cant be found and giving me some reasons why it might not be working. Is there something special with the PICAXE Serial Programming Cable vs. mine. Any other help?

Thanks so much.


well thats the way i have it
well thats the way i have it pinned and still no recognition with the programmer.

so i got the new serial

so i got the new serial programming cable, and still not working. I have the PICAXE28 board and the PIC16F886 chip(which i asume would be the 28X1). I have the COM 1 port plugged in and enabled , setup is all defualt, 4.5v(x3AA), Software installed, and still when I press Run I get the cannot connect error message. It is frustrationg to but something that doesnt work, I have an old Pan-Tilt unit that I found in a recycle bin that works just fine through the com port. I work at NASA in a lab and we take precautionary measures to avoid ESD(electrostatic discharge- pretty much shocking and frying components with built up static in the body) is there anyway the chip/board could have been damaged during shipping or me handeling it? I am just very new to this whole programming thing dont even know how to do anything with the PICAXE other than PICAXE>Run. Im at a loss right now. Any advice would be welcomed.


Make sure that you are set

Make sure that you are set to use the correct picaxe in the view dropdown under options for the picaxe programming editor. You can also test the connection by clicking on the firmware button when you chose the correct picaxe. I think the default is the 8m, but I could be wrong. Also while in the options window, check the com ports and make sure you have one available. they’ll be grayed out if they are not. Refresh and test when in the com window.

put some simple code in the editor like high 1, low 1 end…that should do it.

Good luck !

ok, so does my picaxe have
ok, so does my picaxe have to be plugged into my robot(does my robot have to be assembeled) to be able to know if it is connected and working? I am stumped.

Stupid question… Do you
Stupid question… Do you have it connected to approx 5 volts? Also is the com port setting in th epicaxe editor matching the com setting found under devices?

i thought there were no

i thought there were no stupid questions. 4.5 volts, yes COM1 is selected and enabled in the editor are device manager. But it wont recognize or connect to the picaxe.

Did you try my suggestion

Did you try my suggestion and make sure that the correct picaxe was selected?

it just needs to be powered. I’m might be off on this, but I thought that I’d read that it should have at least 5 volts when trying to program it. even the 3-4.5 might not do it…again, I could be wrong.

I’ve used 4.8 without a
I’ve used 4.8 without a problem. I’ve heard of people using 3.6 and 4.5volts too.

I have the PIC16F886 chip,
I have the PIC16F886 chip, which I assume is the 28X1. The board that came with my starter kit says 28X, I’ve tried every picaxe mode and every freq. I have another COM controlled Pan tilt unit that works so i know my COM works.