Picaxe 28 circiut board robot

I am trying to make the robot in the start here section.  The motors work when I hold the wires to batteries but when I try to attach them to the board they don't work.  I have followed the instructions carefully and soldered the wires to the pins (as I don't have connecters).  I have tried several times and am still stuck.  This robot is for a school project and has to be ready in two days.  I really don't know what to do can anyone help?


Can you take a picture of

Can you take a picture of your board and attach it here? And give us a bit more information on your setup.

Indeed. Please make sure

Indeed. Please make sure your pictures are well lit and in focus, and that your description of your set up is very clear.

We can help best if you give us good info.

Ok, It’s the robot in the

Ok, It’s the robot in the Start here section. The two wires from one motor go to A and the two from the other motor go to B, thought at first it was my solder, so i re-soldered but that didnt work. It works when the wires are just held to the battery thing but not when they’ve been soldered to the pins and into the board.

The pictures aren’t very good as it just goes blurry




Thanks, I’ve uploaded the photos in another comment (me being a numpty didn’t twig to reply to the comment!)

They’re the best I can get them in focus with you still being able to see whats going on.


A good, clear picture of

A good, clear picture of your board and the soldering job as seen from the top and bottom of the board would be really helpful.

  • For example, a common mistake is to have one or more of the chips inserted in the board backwards. But your picture is too blurry to see if this is the case.
  • Another common mistake is poor soldering contacts, or solder bridges connecting something you don’t want connected. Again, we can’t quite see that from your pictures.
  • So please take the time to get some good pics posted. Honestly, it will help a lot.

Also, please provide some detail about your set up, and what you have done so far.

  • What batteries are you using to power the board (how many and what type)? Are the batteries new or freshly charged?
  • Did your program load properly from the Picaxe Editor?
  • Post your code as an attached file. The problem could be hardware or software at this point.
  • Are you able to get the board to do anything? Flash an LED, etc?


Erm im using 3 new

Erm im using 3 new non-rechargeable batteries, and I havent managed to get it to the programming stage yet.

The board works with an LED.

We’re trying to work on the photos, but i cant get them zoomed in close enough without loosing focus and them going blurry. I’ve checked the chips against the instructions to make sure they’re right and they look the right way round.

I’ve also checked the solder and there arent any solder bridges

this is a little confusing:I

this is a little confusing:

I havent managed to get it to the programming stage yet.

So, did you upload any program at all to your 28x1?

And do you have a multimeter

And do you have a multimeter available?

What I do for clear pictures

What I do for clear pictures is get as close as possible that the camera will focus on. Even if it is zoomed way out and the thing you want to display is only a small part of the picture, this is OK.

Then, take your picture in a image editor (there are many free ones online) and crop the picture down to include just what you want to show. Most digital cameras today have plenty of resolution, so cropping down will still provide you will a nice clear picture that we can see detail on.

Better Picutres






Thanks for all your help.  Here are some better pictures.  Sounds like a stupid question but someone just asked me if I have to program it before the motors will work.  I haven't programed it yet.


Yes, you have to load a program into the Picaxe. The Picaxe tells the motors driver to turn on/off the motors, so, no program = no motors running :wink:

So, probably the problem was

So, probably the problem was in software, in absence of it to be precise :slight_smile: So, you have to jump into programming part:

This code should make your motors spin :

high 4

low 5

high 6

low 7

Thanks for the clear

Thanks for the clear pictures. That is SO much better. Keep this in mind for next time, because we could have helped you much quicker.

As some others have already noted, you need to program the Picaxe or it will do nothing at all. Read through the start here instructions and it will explain all this clearly.

However, with your new pictures, I can also see you have at least one physical problem.

  1. You have the two smaller chips insterted in the wrong sockets. Swap them! The motor driver is the one marked L293D. This needs to be inserted in the slot that is next to the four motor pins. The other chip is a resistor pack. This needs to be inserted next to the row of digital output pins.
  2. I see you soldered wires directly to the motor pins. This will work fine, but if you bought the LMR bundle, you’ll have jumper cables with female headers on them. These are much preferable to soldering, so you can easily remove or swap motor connections if you need to. If you stick with solder, be careful that you don’t short any of those pins, or you will be very unhappy.


Thanks for the help.I can’t

Thanks for the help.

I can’t get the computer to recognise the USB cable and it keeps coming up with an error saying to make sure its connected to the computer, batteries and it may need resetting, I’ve tried to reset it how it says, but it still won’t recognise it and it’s deffinately plugged in to everything :S

OK. That is a different

OK. That is a different problem, and it is one that many people run into. You can see a post here about it. Take a look through and see if any of the suggested fixes help you. Here’s another one.

Basically, the advice comes down to:

  • Be sure you are providing between 4.5V and 5V to your Picaxe board
  • Be sure you are using a real Picaxe USB cable (there are electronics inside)
  • Be sure you have downloaded the latest drivers for your cable from this site (scroll down for the USB cable driver software)
  • Be sure you have selected the right COM port in the Picaxe Editor (the one your computer assigns to the USB cable)
  • Be sure you have selected the right Picaxe processor in Picaxe Editor (something like "28X1/40X1)

Please verify that ALL of these things are correct. If it is still not working, post a separate forum question with lots of details and we’ll try to help. Keeping separate problems in separate posts helps keep the site more user friendly.