Phoenix with Botboarduino - unable to move servos through BotBoarduino

I just purchased a the Phoenix and am having trouble getting it to move. Here’s what I’ve accomplished so far:

  1. Construction for the most part was straightforward following the assembly guide on the Lynxmotion site. I’m using an SSC-32u USB board to power the servos and it seems that the guide was designed for an SSC-32 board, but that didn’t seem to be a major problem.
  2. I compiled and uploaded the BotBoarduino_CH3R_PS2.ino program with no problem.
  3. I ran into a problem when I downloaded the Hexapod Calibration software and tried to connect. I could not get it to connect when I had the USB plugged into the BotBoarduino board, so instead I plugged the USB directly into the SSC-32u and I was able to run the software and calibrate the servos with no problem. I initially had the TX, RX, GND wires from the SSC-32u wired incorrectly - that might have contributed to this problem. I’ve subsequently fixed that problem.
  4. Next I turned on my PS2 controller and put power to the robot. All the lights on the BotBoarduino board and the SSC-32u seemed to function normally. I hit start on the PS2 and I heard some tones from the speaker. I hit some buttons and I hear tones and see the lights on both boards responding. When I hit the triangle button or any of the other buttons that are supposed to make the robot move, I get no response from the servos. The battery is fully charged and plugged in with the switch on.
  5. I saw in the PS2X_lib.h file that I should be able to print out debug to uart. I think this might be a start in helping me to troubleshoot, so I uncommented the DEBUG lines. I’m using gtkterm to look at the serial debug data, but as soon as I open the port the BotBoarduino sends a continuous stream of data and does not stop transmitting - not sure if that’s what it should do or what I should be looking for.
    Any insight you could provide would be greatly appreciated. Thanks.

Problem solved. In the Hex_Cfg.h file I noticed that the baud rate was set to 38400. As soon as I changed the baud on the SSC-32u to 38400 everything worked fine. Of note - the assembly instructions for the Phoenix say to set the baud to 115200.

@Jowler Welcome to the RobotShop Community, and happy you were able to resolve the problem. We’ll look into the issue in the assembly manual.

1 Like