Neato XV-21 and lithium battery

I recently purchased this but my XV-21 is giving me Battery issue 0002 error. It seems the battery is disconnected. With the lithium battery installed, the XV-21 doesn’t even turn on if it’s not docked.
Anybody knows how to solve it? This XV-21 is an older model which doesn’t have a on-off switch.

@hongt, it might be a problem with the new batteries, or it is a problem with the battery connectors in the robot. We would recommend that you contact the seller on Amazon and have the batteries exchanged, it might clear the issue. We would suggest to purchase Neato genuine batteries for your robot.

I’ve tested Li-Ion batteries today, there’s no problem with the connectors.
The Li-Ion batteries have special electronic board installed to control the charging process called PCB (Protection Circuit Module). When tested using iMax B6 charger on Ni-Mh algorithm, similar to what Neato XV uses to charge the original batteries, the unit disconnected the battery after it was fully charged.

Neato expects the voltage to drop slightly at the end of Ni-Mh charging, but instead it gets complete battery disconnect (by PCB) and therefore generates the battery error 0002 (Battery overvoltage)

So I guess in order for the Neato XV to work properly either:

  1. The Neato would have to be re-programmed to use Li-Ion charging characteristic Or
  2. The PCB would have to be (re-)designed to “pretend” to be Ni-Mh

I found some more information here: “A battery supplied with only protection circuits would have to be used with the unpublished USB command SetConfig BatteryType 3 to convert the Neato charger to Vorwerk lithium, voltage regulated mode”


Rob Kostecki

[font=Arial][size=2]I’ve just resolved the issue by reprogramming the Neato.

  1. Connect USB cable to your PC

  2. Open Device Manager (in Win 7). Scan for hardware changes and install the driver (Port COM). Alternatively download “Neato USB Driver”
    Once done you should see “Neato Robotics USB Port (COMX)” under Port

  3. Download terminal from here:Tera Term [/size][/font][/font][size=2][/size]
    [font=Arial][size=2]4. Connect using Serial Neato COM port, usually the last on the list

  4. Type “help” to check connection

  5. Type “SetConfig BatteryType 3”

Job done. Now the error should be gone - well at least it’s gone on my Neato XV-21

Rob Kostecki[/size][/font]

1 Like

Hello Rob,
Thanks for your posting. I have a Neato XV-14 and need to replace the batteries and was thinking about purchasing the lithium battery packs for my XV-14. However, in case I run into the issue that you did, I hooked up my Neato to my Windows 7 laptop, installed drivers, and downloaded Tera Term. Opened Tera Term, and connected to COM 8 (where my Neato USB Driver shows).

However, I seem to be stuck at Step 5. I cannot seem to type in help, as all it shows on the screen is “h”.

Am I missing a step somewhere? Any help would be greatly appreciated.

Thanks for your time.


Since there’s no updates available for the XV series anymore, it is possible that an error occur when trying to run the software to your computer.

To replace the battery, you don’t need to plug the Neato to your computer. All you have to make sure of is that you recalibrate your battery once the new ones are installed.

Thanks for your reply jmichaud.

I was just wondering if the lithium batteries that hongt was talking about was the same brand/type that rkostecki tried. It seemed that hongt was not able to use lithium in his XV.

rkostecki mentioned he was about to get lithium working in his by reprogramming his Neato, so if I purchased lithium packs such as the one hongt purchased (by Lithium Power Inc), if I would have the same problem with my XV-14.

Thanks again.

Registered for an account just to thank @rkostecki and confirm that his method of using the terminal to update the XV-21 was exactly what was needed to get my neato to recognize the Li-Ion batteries that I recently installed.

Thanks again!

Thank you @rkostecki for helping me to solve the Neato- problem.

I’m a new and have set the config to 3 but how can I turn back to the default (Nimh)
I know this an old topic but maybe someone can help me out here

1 Like

Thanks so much for this!

I want to upgrade my Neato Signature to lithium batteries using: SetConfig BatteryType 3

Like yourself, before I start, I wondered what the command would be to reverse things - in my case to recognise my original NiMh batteries.

A look at the the Neato programmers manual GetVersion command: Neato Programmers Manual 20140305 ( seems to indicate that the command should be: SetConfig BatteryType 1 as “1” is present in the battery type description - " BatteryType,1,NIMH_12CELL"


So I will use GetVersion to check my current config before and then after I config using the Battery command to make sure.

So in my case, the current config is:

Neato before.

  • using the original NiMh batteries.

After entering: SetConfig BatteryType 3

Hello, I have purchased lithium batteries for my NEATO XV Essential (XV-16). No battery errors but they do not charge.
So I followed the SetConfig BatteryType 3 procedure.

Do I have to do something else? Are the end-of-charge sensors in the battery or the NEATO?
Thank you in advance.

Bonjour, j’ai acquis des batteries lithium pour mon NEATO XV Essential (XV-16). Pas d’erreurs batteries mais elles ne chargent pas.
J’ai donc suivi la précédure SetConfig BatteryType 3.

Dois je faire autre chose? Les capteurs de fin de charges sont ils dans la batterie ou le NEATO?
Par avance merci.