My wheels do not move

I'm trying to make

My wheels do not move when I program it. This is the code I use:

I'm pretty sure that the pins are soldered correctly to the board. I already re-soldered them 3 times and they look just like they do in the pictures that are in the instructions.

My motor contact fell off, so I followed the instructions on . I'm sure they are connected right because when I put a battery pack to them, they move. So the motors do work and aren't fried. 

I'm sure that I connected the pins to the board right. I put both of the pins of the wheel on A, and the other pins of the wheel on B, just like the instructions. 

I'm also sure that I put the chips to the board correctly.

Everything else work EXCEPT the wheels. The servo moves when I type in:

servo 0, 75

wait 2


Anyone have any ideas to why my wheels do not move? Both of them do not move.

**Could it be my batteries? **

I use Energizer max AA20 batteries.

Are they too weak for this?

try a breadboard

don’t solder anything until you know the chip is going to work. try different combinations of high/low for 4,5,6,7, connecting the picaxe to the motor driver to the motor all on the breadboard. no soldering, just change which lead goes where right there on the breadboard. your code should work, so you now must check the connections on the chips and the motor.

will the motor move if you connect one side to 6v and the other side to G? Then it works.

If the Picaxe can blink an LED, then it works.

If both of those work and you don’t have a broken connection anymore, your motor driver is the problem. but the problem is 90% likely to be a broken or wrong connection. Do you have the papers that came with the project board? They contain a perfect schematic of how the h-bridge connects to the axe and the motor.

YES! When I connect one side

YES! When I connect one side to 6v and the other side to G, it does work!


But I’ve tried soooooooooooo many different combinations (so, so many combinations) for high/low and it doesn’t work.  

If the motor driver is the problem, how do I fix it?

Could the pins on the board be the problem?

Do pins get deffective after a while, or are they just ways to connect wires?

If the motor driver is the problem, how do I fix it?

Try this.


high 4

low 5

high 6

low 7

goto main


No, it still doesn’t work.

Are all your chips in the same way?

They have this little semi circle that lines up with the connector on the board.  This should be the first thing you should check.

Like this.


You see how that little indent on the right on all the chips is facing the right.  Also did you swap out the chips? The one that came in that spot orginally is for sounds.  You need to swap it to the L293D for driving the motors.


Yes, they are the same way and I did replace the chips

The chip that should be removed is ULN2803A

991WE VW
MYS 99 022

This is the chip that is supposed to be removed, right?


If you take the two leads from the motor and plug one into V and one into G while the robot is on does it spin?




This should be the L293D.


Solution found

Via the shoutbox it was determined that the four header pins that connect to the motor were all connected together with one big ball of solder. After resoldering each pin to its own pad the motors worked as expected.

A story of success and a testament to the sturdiness of the L293D.