MKR IoT Carrier does not connect to sensors


I require your help regarding a problem I’m encountering.

The MKR IoT Carrier that came with my Arduino IoT explore kit is having trouble connecting to sensors. I have completed Activity 1 of the kit, but whenever I disconnect and reconnect my board via USB, the serial output says:

19:56:33.680 -> Error detected!
19:56:33.680 -> Pressure sensor is not connected!
19:56:33.680 -> Environmental sensor is not connected!
19:56:33.680 -> Air quality sensor is not connected!

It usually works on a fresh upload but occasionally cannot connect to the pressure sensor.

Hardware concerned:

MKR1010 WiFi Board & MKR IoT Carrier

Software concerned:

Arduino IDE 2.0.3
Windows 11
My code:

Troubleshooting steps already taken:

I have tried calling .begin() on the sensor classes of the carrier in the setup function to avail. I have tried including a longer delay between the serial connection and calling carrier.begin().

Additional information:

For some reason, the LED_BUILTIN does not blink using the Arduino Blink sketch when my IoT carrier is connected, but blinks fine when the board is solo. I am not sure if this is related to the issue with sensors or not, but I’d also like to understand why that’s happening.

Thank you so much in advance for your help!

1 Like

Hi @linguini1 and welcome to the forum :slight_smile:

If you still haven’t solved this problem, I would recommend posting about in on Arduino forum and they should be able to help quickly.

Thank you.

Hello @linguini1
I’m using the Explore IoT Kit. I just saw your post. I’ve been struggling with Arduino’s MKR IoT Carrier’s sensors for a few months. The measurements from the carrier seem to be very inaccurate. Have you managed to get it to work properly?? Have you done the Activities in the EIoTK?? What’s your experience so far??
Thank you for any feedback.


Hey, I spoke with Arduino support about my issue and they told me it was a known issue they are working to resolve. In the meantime they told me the best fix is to click the “reset” button on the back of the MKR1010WiFi board after plugging the device/carrier back in. I have not particularly noticed inaccurate measurements, but I am struggling with the PIR sensor detecting people right now. I am not sure that I have done EloTK activites, but I have done about half of the activities associated with the IoT Explore Kit. I have been enjoying them so far, but most of the work/learning so far has come from troubleshooting devices. My SD card doesn’t seem to work with the carrier case despite my best efforts. I have not had a chance to buy another one to test. The PIR sensor hasn’t quite been behaving as expected either. But all the IoT Cloud/Dashboard activities have been going smoothly thus far.

1 Like

Thanks a lot for the prompt reply. It seems you are doing same as me. BTW: EloTK, I meant Explore IoT Kit.

I’ve had lots of trouble with the PIR sensor, given up on it. But I also find the sensors on the carrier to be way off compared with other sensors I have at home (temperature, humidity, gyroscope, etc). In particular, the IMU’s gyroscope is supposed to provide degrees per second in X,Y,Z but I find it does not respond always the same way when I rotated about the Y-axis for example (Activity 6 in EloTK). Have you done Activity 6, uses IMU’s gyro and PIR for classroom door?? What I mean here is: if what comes from the gyro is not accurate, the PIR cannot work properly either. There is also the delays introduced by the cloud. Have you completed all activities??

1 Like

I am only finished activity 5 on the kit. I’m a full-time student so I haven’t had much time to complete the activities. I haven’t specifically noticed any inaccurate measurements with the other sensors yet but I will keep an eye out.