mechDOG - issue getting LLS adapter & botboarduino working

Hi There!

Greetings from tiny Denmark!

Me and my son are building the fantastic mechDOG project and it’s so much fun and really great instructions. We’re almost there, but are stuck getting the LLS adapter board and the botboarduino working together.

It seems to be some sort of a power issue. All the board are working individually (for instance the botboarduino when attached directly to usb, where we can read signals from the radio control receiver).

When we attach the battery with the adapter board in Arduino mode, there’s full light in all servos, but the yellow light on the botboarduino are really weak and there’s no light if we attach the radio control receiver. When we switch it to USB mode, the botboarduino isn’t registered on the computer (the botboarduino board works fine when attached directly to the computer, where the yellow light is also much brighter).

Sorry if we missed an obvious step, but we’ve really read the instructions over and over :innocent:

Villum and Niels :slight_smile:


Hi Villum and Niels,

Nice - Post pictures of your build here on the community, it’s always fun to see.

Regarding the BotBoarduino and it’s power source, there are a couple of jumpers to properly set on the board.
Unfortunately, this doesn’t seems to be covered in the mechDOG quick start.

Close to the screw terminals, you will find the “USB or EXT” jumper for power, it has to be on “EXT” to work out of the LSS-Adapter power.
The “VS=VL” jumper also need to be there, if not already.

Our team will make the addition to the user guide soon.

All the best,


Hurray, it worked :tada:

Thank you, so much for the fantastic reply with super clear instructions. Much appreciated :pray:

Can’t believe we missed it - we thought of something like that was the issue and looked in the docs for both the adapter board and the botboarduino. However the docs for the latter isn’t as great for newbies as the rest of your awesome docs)

Next up is building and mounting a small Nerf gun that can be controlled from the RC!

Our real dog isn’t too happy about the new inhabitant, though :smiley:


We also updated the code for the Simple Gait example, so that the dog isn’t doing the trot in place all the time, but only when the button switch is pressed. It makes it easier to control.

It’s done by switching the logic in line 332 (so it becomes button == 0).


Now this I’m looking forward to!


That’s actually an issue, it’s not supposed to trot on place unless the button is pressed.
Sometimes the Remote is “reversed” and the action is ON by default, but glad you fixed it…!

I suggest you play with the Inverse Kinematic example as well:

Keep the pictures / videos coming, that’s so nice.