Lynxmotion SSC-32U group command (18 servos) not working

First of all, please excuse my poor english, I am not a native speaker.

I am currently working on a hexapod-project for my university and I am using the Lynxmotion SSC-32U board to control 18 servos. I wrote up a simple C+±method, which generates a group command and sends it over a COM-port to the controller-board via the USB-Port on the controller-board.

In my previous tests I was just testing the group commands with 3 servos (1 Leg of the hexapod) and that all went very smoothly (for each leg). Last night I tried to scale my tests to the whole hexapod and tried to use one group-command to set the pulsewidths of all 18 servos, but that did not work.
I am using the same method as before, but simply appending more servos to the command.

I am not using the time or speed specifier with the command, just the pulse-width for every servo. After the command gets sent, all servos twitch for a short moment, but don’t move much and both the baud-LEDs glow constantly afterwards. I’ve got the VS1-terminals hooked up to a lab-bench-powersupply and the drawn current decreases to the idle-current, after the group-command was sent. I’ve got the jumpers from VS1 to VS2 and VS to VL installed. The firmware is “SSC-32-V2.50USB” according to the servo-sequencer-utility.

Does anybody know, what is causing this?
FYI, this is the group-command, that gets transmitted to the controller-board: “#0P1500#1P1500#2P1500#4P1500#5P1500#6P1500#8P1500#9P1500#10P1500#16P1500#17P1500#18P1500#20P1500#21P1500#22P1500#24P1500#25P1500#26P1500/r”

Welcome to the community! It might be that moving all of the servos simultaneously creates too large a spike in current which your power supply cannot handle. To debug, start by sending commands to three servos, then four, five etc. until there are issues.

1 Like

yes, that actually seems to be the problem. thank you very much for your fast response! well, now I got to think about getting a new power supply :smiley: