Lynxmotion HT1 Servo Lights up but it unresponsive to commands

We recently purchased a number of smart servos and were able to get them all set up with separate IDs except for one of them.

The problem servo cycles through red, yellow, and holds on green once plugged in, but is then seemingly unresponsive. Serial commands to control the servo and set its ID have seemingly no effect, and holding down its button to enter the button menu ( doesn’t work.

Anyone else have/resolve this issue?

@GnarlyWhale Welcome to the community. Given that it goes through the startup sequence of the LED flashing red-> yellow-> green it’s promising that the servo might be ok, just in a weird mode. After the green LED however, does it go through any colors which might indicate its mode or does it not “end” the sequence and stay on green? Normally there should be another color, such as yellow or blue. Nevertheless…

  1. Ensure that servo is the only one physically connected on the bus so there’s no possibility of any other servo having an impact.
  2. Try a factory reset, described at the bottom of the button menu:

This involves keeping the button pressed and then powering the servo, releasing only once you see yellow for bootloader mode. The LED should then pulse yellow, at which point you press the button three times. The LED should then pulse magenta waiting for confirmation, which is three button presses. Red should indicate factory reset. You can then power cycle and see if you can connect via serial. The default baud should be 115200 - try to connect via the LSS Config.

Await your update.

Hi @cbenson, thanks for your reply.

The servo indeed holds on yellow after going through the start up sequence.

I attempted to run the servo through the reset as you suggested [hold button, power servo, release once servo holds on yellow], but the servo never started to pulse yellow.
I then tried to trigger a mode switch by sending a constant 5v to the RC Rx line for over 30 sec but no luck.

Hi @GnarlyWhale,

Welcome to the RobotShop community!

It seems like the bootloader might be corrupted, but just in case please try the following:

  1. Ensure you have only the problematic LSS connected to your bus.
  2. Hold the button and power the servo. Once the LED bar is yellow let go of the button.
    (at this point the yellow light should blink, but even if it does not please continue to the next step)
  3. Start LSS Config and connect to the bus.
  4. The LSS won’t connect but you can still use the Firmware button at the top (useful for recovery). Press the button and selected the recommended firmware (v367 at time of writing) and start the process.

Let us know if it is able to write the firmware and if not we’ll offer a replacement.


Hi @scharette, thanks for the response.

I attempted your solution but unfortunately no luck. The released the button after the LED went through it’s power-up and returned to hold on yellow, connected it to the serial and launched LSS Config. The program indeed did not connect, but I ran the firmware update as you suggested, then power cycled the servo, only for it to remain in the same condition.

Thanks again for your assistance.

1 Like

The full upload of the firmware went through? (i.e.: you saw a progress bar in the command line at the bottom?).
If so, this would indicate that the bootloader is partially corrupted (parts of it work, parts don’t).
Regardless, this means we’ll have to replace your faulty LSS.

This topic was transferred to internal RobotShop Support.