Lynxmotion AL5D, SSC-32U Servo Control/Connection

I ordered the Lynxmotion AL5D botboarduino arm for my senior design project. Everything has been assembled, and the servo pins are all plugged in. However, as soon as I plug in the board to my laptop, the base servo begins rotating in one direction. I’ve tried using both the LynxTerm and SSC-32 Servo Sequencer, and both appear to recognize the board, but nothing I’ve tried through those appplications have been able to move any of the other servos or stop the base servo from moving. Any suggestions for trouble shooting would be much appreciated!

@harmless102 Welcome to the RobotShop Community. To confirm, you have the following kit?

If so, this is NOT compatible with Lynxterm nor the SSC-32 Sequencer software. Those are both compatible with the SSC-32U servo controller, whereas you have an Arduino compatible BotBoarduino programmable microcontroller.

SSC-32U Servo Controller:

Arduino Compatible BotBoarduino Microcontroller:

The BotBoarduino version of the AL5D is intended for people who are prepared to do some programming using the Arduino IDE ( to download the software). There is sample code on the Lynxmotion GitHub page, as well as sample code if you wanted to use the arm with the Lynxmotion PS2 controller.

It’s important to read through the BotBoarduino guide in order to know the jumper and power setup (or else you can fry the electronics and/or the servos).

If you didn’t want to program anything, you can purchase the SSC-32U servo controller above and follow the wiring guide in that manual. You can always use the leftover BotBoarduino for future projects.