LSS Query Problem


I just recently bought the LSS High Torque Motor with the Adapter Board and started playing around with it. It’s working great so far but I’m having trouble reading the data back in. I’m using the Arduino LSS_Query example that I downloaded from the Github link and it’s just constantly returning 0 for every value. All the other examples seem to be working and so I’m not really sure what the problem would be.

I’ve also tried merging the Wheel and Query examples so the motor rotates but the values are still 0. Any tips/pointers would be appreciated.


Hello @Drayxs !

I’m sorry to hear that. Did you try the official configuration software? Maybe, just to debug, you could try starting your motor using it and see if the values are read. If they are being read, then it could be a protocol problem when you’re reading from your arduino.

Hope this could help you :grin:

1 Like

I have tried but I also can’t seem to get it working haha. I’ve switched it over to USB, chose the right COM port, and made sure the motor is being powered but the connection always seems like it’s timing out.

Hi, I am sorry to read that you didn’t solved the problem with your product. I can try to help. @AudioVOx What do you think?

Hey @Drayxs,

Welcome to the RobotShop community! :slight_smile:

Lets dig into this issue so we can help you resolve it quickly! I’ll break down the info you’ve provided up to now so we can determine exactly what is causing the failure to read from the LSS.

I assume this means you are able to make the LSS perform actions that you send to it?
Are those sent over USB from a PC/laptop/etc.? From an Arduino (or similar microcontroller board)? Something else?

I’ll assume you are using this file as-is (i.e.: no modifications except maybe the ID used).

Not being able to connect using the LSS Config [RB-Lyn-1026] is our first red flag, so we’ll investigate this first. Once we have that working we’ll move own to the Arduino issue. It is very likely they are both related.

Lets start simple and go from there.

  1. Please re-create the following setup:
  • Your LSS-HT1
  • Your LSS Adapter (set to USB) with nothing connected to it (no Arduino/etc., only one LSS)
  • A LSS cable between the two
  • A power source (6-12 V DC) connected to the input for the LSS Adapter.
  • A USB cable to connect from your LSS Adapter to your PC (running LSS Config).
  1. Once the setup is done, please take some pictures of it making sure to clearly show all the components. Attach those to your reply here.

  2. With the LSS powered through the LSS Adapter (from your power source) and connected to your computer by USB, open Device Manager. In it you should have a category named something like Ports (COM & LPT). Expand it to find a COM port named USB Serial Port (COM???), where ??? stands for the COM port number.
    If there are more than one device under Ports (COM & LPT), disconnect any other devices (such as Arduino and etc.). If after doing so there are still more than one, disconnect the LSS Adapter and wait a few seconds for its port to disappear. Note down the COM port number of the one that disappeared. Reconnect it and confirm the port number once it shows up again.
    Please mention your COM port number for your LSS Adapter in your reply.

  3. Open LSS Config. Select the proper COM port from the dropdown and connect. Your LSS should be found within a few seconds. If you get any error messages/pop-ups/etc., please post a screenshot of it here. You can use the PrintScreen button on your keyboard and then CTRL+V in here to paste the image. You can also modify it in “MS Paint” first if you prefer to remove other stuff that is irrelevant or that includes personal information (desktop, etc.).

  4. If it does connect properly / finds the servo the software should start displaying telemetry in the main window/graph area. Go to the console line at the bottom and type in “LED5” and press enter. The LED of your LSS should change color. You can also type “QLED” and you should see in the console something like “*0QLED5”, where 0 will be the ID of your LSS if you changed it to something other than the default (0).

Let us know how this all worked out. Looking forward to your reply after following these steps.


1 Like