LSS HT1 Servo control problem

Hi, I have recently purchased the LSS Conveyor HD Kit & LSS-HT1 for an exhibition.
I have powered and connected the HT1 and can connect via RS232 (using a Sabranet USB2 to Serial adaptor and my Win10 laptop). This seems to find the servo and runs the firmware update successfully but then fails to find the servo:

I saw a few posts about a similar issue which suggested the servo might be in RC mode. I have tried using the button menu to set the servo to LSS mode. Power → LEDs initialise → constant red LED → but then further button presses changed nothing.
I tried the update/reset sequence and successfully initialised the FW mode and then followed the sequence to factory reset but then the LED just flashes continually, also after a power cycle.

I think the servo is in a strange state but I cannot find a way to recover it. Can you provide any guidance?


Hi IG88,

Would you share a picture of your setup ?
Most importantly the connections between the Adapter and LSS.

There are no communication between the serial adapter and the LSS at that point.

Also, if the LED is flashing upon startup it’s probably in RC mode.

“Power → LEDs initialise → constant red LED → but then further button presses changed nothing.”
You should hold the button for 5s to enter the menu, then follow the button menu. (link)

Best regards,

1 Like

Hi dialfonzo, thanks for the quick response.
Here is a photo of the setup. If it is not clear then pin2 = rx, pin3 = tx and pin5 = gnd (common with power ground)

Currently at power up the led is red and flashing. If I hold the button for 5s it goes solid red. If the press the button twice to enter LSS mode it goes back to flashing red and after about another 5 seconds I get a red, amber, green initialisation sequence, then back to flashing red.

Hi IG88,

Quite hard for me to understand what’s connected where.
What need to be done is:
USB Adapter TX to LSS RX
USB Adapter RX to LSS TX
USB Adapter Gnd to LSS Gnd (negative)

1 Like

Hi dialfonzo,
Okay I had RX ad TX round the wrong way and have corrected this but I still see the same issue.

If I start the firmware update from LSS Config this runs without errors and reports the latest firmware so it seems like some communication is happening. But afterwards it reports “No servos found!” after scanning at all baud rates.

Currently the status LED is pulsing red. I have been unable to successfully perform a factory reset, after a power cycle the status LED continues to pulse red.


1 Like

Hi IG88,

Pulsing red could mean two things:

  1. A serial command is sent to the servo but the servo do not recognize it.
  2. The servo is in RC mode and do not have any signal IN.

You claim that you can do a firmware update with the LSS Config, are you initiating the update in the LSS Config or you put the servo in the loading mode with the button menu ?

  1. If using the LSS Config to initiate the update, it means the servo is in Serial mode to start off.
  2. If using the button menu, there is still a chance that you are in the RC mode.

Just did two little videos to help out:

Lynxmotion LSS - Set RC mode with button menu

Lynxmotion LSS - Set Serial/UART mode with button menu

All the best,

1 Like

Hi dialfonzo,

Below is a video showing what I see. The first part of the video shows power up to reset (button pressed and then servo powered). The steps for a reset look correct (yellow pulse → 3 button presses → magenta pulsing → 3 button presses → red flashing) but the red LED pulsing continues even after a turning the power off and on. On your video the red flashing was a double pulse in RC mode.
The second part of video shows power up and red LED pulsing. If I press the button for 5 seconds the LED stays constant red and pressing the button twice does not change the LED status.

1 Like
  1. Can you hook only the Power to the LSS ?
  2. Are you sure the GND is common between your PC / Adapter / LSS ?

Constant flashing RED could mean it’s in Error mode and there are a couple of reasons for that.
Could be you made a mistake in the wiring and broke the Serial part of the internal control or a Sensor of some sort is not working properly inside.

Let me know what it does with only power on first.

1 Like

I found that the power supply I was using was borderline and perhaps not providing enough current. I have replaced this with something that definitely has enough current (2A) and tested again. I can now get the servo set to RC mode the same as shown in your video. If I switch to serial mode after setting the mode the LED stays solid red. After this the LSS Config still does not find the servo.

Could the servo serial interface be damaged perhaps?

1 Like

Nothing is impossible with custom wiring but I would doubt it’s just a simple mistake.

What are you using as the power supply exactly ?
Steady red is usually an error unless you set the default color to RED with the LSS-Config. Have you set the color before ?

The errors include:

  • Over current
  • Over Voltage

Are you sure the TX of the adapter is connected to the RX of the servo and RX of the adapter to the TX of the servo ?

1 Like

It is a just a standard 12V/2A mains adaptor. I am measuring 12.4V with my multimeter.

I swapped the RX/TX around several times, so have definitely covered this. Also tested the USB to RS232 convertor with another device and this works.

As far as the LED is concerned, I have performed a factory reset and now the red LED is not persistent so I guess I had inadvertently set this to red previously :slight_smile:

Getting closer but still no serial comms.

So - You were able to do the software update once then nothing since.
I will advise you to do the software update again:

  • Power your LSS with your serial adapter connected
  • Start the LSS-Config
  • Select your COM port
  • Click Connect
  • Go directly to the “Servo” drop down and select “LSS-All”
  • Go to Firmware and select the 370 and update

If this still works, let it do the update all the way to the end.
It will let us know if the servo Serial communication does work or not.

1 Like

I’m not convinced the firmware update ever really worked. I have just tried it again as per your instructions and it says it completed successfully but still not servo found at any baud rate

I then tried again without the serial comms even connected and it still reports the firmware updated successfully.

Is it worth bypassing the LSS config and talking directly over serial comms to get the servo status?

When doing a firmware update, the LSS-Config is sending a command for the servo to go in Firmware Update mode and proceed with the update. If you do not have any servo pre-scanned it will broadcast this to all IDs which allows for updating all of your LSS on one bus but this is without confirmations that it’s been received on the other end. It didn’t work then.

You can force the firmware update mode with the button menu, once in that mode you can try the LSS-Config update.
When the update works, you will see a Blue LED with Purple flash when a package is read (5s).

  1. Hold the button
  2. Power up your LSS
  3. When you see the Yellow LED you can release the button
  4. Should be a pulsating Yellow LED
  5. Proceed with firmware update in the LSS-Config

About your question, yes you can bypass the LSS-Config but greatly doubt you will be successful if you can’t even proceed with a firmware update. If the above doesn’t work we will see what can be done.

I had tried this process previously and now a couple more times. I get the the pulsing yellow LED and when the update starts the LED stops pulsing but I do not see the blue/magenta LED pulse at any point. In fact I have to turn off power and back on again before the servo responds to button presses.

Ok - Then no communication to the LSS is working I think.

Do you have the exact models of your serial adapter and adapter ?

Sabranet USB2.0 to serial DB-9, Prolific chipset

AAOTOKK CB9 Screw terminal block

On this image you seems to have the TX and RX reversed.
PIN2 which is RXD is going to LSS RX and should go to TX and same goes for PIN3 that is going to LSS TX and should go to RX.

So the first thing to do is connect them the right way and do the previous test for firmware.

Hi dialfonzo, I already corrected this error :slight_smile:

HI again, just to confirm, I had tried the firmware update with the RS232 connected correctly but I see the same result.