LR3 the Blue Full Light doesnt stop flashing


I require your help regarding a problem I’m encountering with my LR3.

I have been using the LR3 for 2 years now and recently I’ve been experiencing issues with the Full sensor blue light. It doesn’t stop flashing, even after hitting reset or unplugging power for 30 seconds. The light flashes whether the unit tray is empty, installed or removed. It is sitting on the basement concrete floor that is level.

Thank you so much in advance for your help!


The following troubleshooting should resolve the blue light blinking while the waste drawer is empty. Once resolved, the unit should consistently recognize when your cat visits and cycle accordingly.

To troubleshoot the blue blinking, let’s start by power cycling your unit:

1.) Leave your unit powered ON with the blue blinking light engaged & Unplug your power supply from the base

2.) Wait 10 seconds then plug the unit back in

3.) Allow the unit to complete a start‐up cycle. If the light is solid blue, the code has been successfully cleared. If the light is still blinking, let’s proceed with troubleshooting. Let’s empty the drawer if it has waste and reinstall the bag before proceeding.

Note: If you are using a dark colored bag, always tuck it into the tabs.


Let’s check your DFI Lenses for any obstructions:

  1. Turn off the unit and Unplug the power from the base

  2. Remove the Bonnet and the Globe

  3. Inspect the top of the Base where the Globe usually rests. Are there any debris? Small amounts of litter is normal. Clean as needed.

  4. Inside the waste opening there are two clear ““Lenses”” (left and right side). Ensure there are no debris on the Lenses. Sometimes litter can fall/splash onto them. ** To clean the lenses, we recommend wiping them off with a soft damp cloth and/or glass cleaner. Do not directly spray the Base or DFI Lenses. **

  5. Replace the Globe and Bonnet. Reset the black key in the back of the unit into the pocket. 6. Plug the unit back in. If you turned the power off, you will need to power it on and press ““cycle””. Once the cleaning cycle is complete, the unit should be at the Home position with a Solid Blue LED on.

Further Troubleshooting:

  1. If the unit continues blinking blue, remove the waste drawer and press cycle.

  2. Press reset 2x to abort the cycle and return the unit to home (it will level the litter).

  3. If the unit goes to solid blue with the waste drawer removed, ensure there is nothing in the drawer blocking the lenses.

  4. If the drawer is clear, your base needs to be repaired.

If you bought you Robot with Robotshop and your product is still under warranty, we can send you a new DFI sensor.
If not, here is a link to buy a new sensor:

1 Like

Thank you for the help. I followed your suggestions above, and after cleaning the sensors its still not working. No matter what I do when turning the unit back on the blue light never stops blinking. Even with the drawer pulled out. It looks like I need to order a DFI kit. Is this everything it would be, or do I need to consider ordering other parts too that might be the issue instead? I purchased the unit from Costco November 2016.

Just to add to my previous response, is it possible the motor is the issue?

It is very unlikely that your motor failed. Usually, the 3 lights will flash in sequence if it failed.
Most of the time, blinking blue light indicates a faulty DFI sensor.

1 Like

An update to this issue, I replaced the DFI and it is now fixed. The blue light is no longer flashing and the globe cycles upon first start.

However, now after cycling and returning to home, all three lights flash together simultaneously. The only way to resolve is to reset.

I looked into this and it says it cannot find Dump or home. But on after the reset, the globe will dump and return to home with the 3 lights flashing again. Any suggestions?


If the Open Air unit cannot find Dump and/or Home position, the control panel will display 3 lights blinking. If you have recently disassembled your globe please advise.

Please remove the globe and check the black gear connected to the motor. When you press on the black gear with your finger, does it seem loose or free‐spinning? If so, please follow the instructions for tightening the set screw, here:

When replacing the globe onto the base, make certain that the track around the outside of the globe is properly aligned into the groove on the base.

If the unit is plugged into a power strip, try plugging it directly into a wall. Sometimes the issue is caused by a fluctuating power supply, low voltage, or other power issues. If the globe is filled past the fill line remove litter so the fill line is exposed.

Can we ask the specifications on the adapter for the power supply you are using Correct Spec: 15VDC regulated adapter 400mA to 1,000mA.

[Note: If you are using a power supply with different specifications, the Litter‐Robot may appear to work properly; however, inadequate power can cause the unit to malfunction over time.]

  1. While powered on, unplug the unit from the back of the base.

  2. There is a pin in the jack where the small connector from the power supply is inserted. This pin should be split. Find something small and open it slightly if it is not. 3. Plug in the power supply and let your unit cycle. What happens? A blue solid light means the issue should be resolved.

If the unit does not return Home, or does not return Home with a solid blue light, please provide details of any lights on or blinking on the control panel.

*Are the lights blinking all at once or sequentially?

**If sequentially, please provide the colors in sequence.

If the Litter‐Robot does return Home with a solid blue light, there are no issues with the functionality of the unit at this time.


Just to give you a background to my issues. I have owned the LR3 for just over 2 years, and after a year I started having issues with the gear coming loose. After constantly tightening it for about 8 months I found a solution from litterobot and used locktite to fix it.

Immediately after that issue was resolved I had another issue, with the blue flashing light. So I just replaced the DFI, and that fixed the blue flashing light issue.

And immediately after that issue was resolved I have another issue, this time with the three lights flashing together at once (simultaneously). This occurs once the cycle has completed successfully and the globe returns to home successfully after the dump. So I do not know why it would be confused since it did dump and it did return to home. Once I clear the error it is able to dump again, and return to home again, but then returns the 3 flashing lights once again.

My cats have now stopped using the litter robot and I am having a hard time getting them back to using it because of all these issues. What can you suggest to fix the 3 lights flashing simultaneously, as it is already clearly finding the home and it is able to dump successfully? So I am not sure why it is giving the error code.

Hi @tcottrell. Have you tried the suggestions in my previous reply?


The power supply is the original one that came with the unit. I will confirm if the pin is split when I get home.

Is that all it could be with 3 consecutive lights flashing, or is there other things I can check?



I have done as suggested and split apart the pins on the power jack. This temporarily fixes the problem as it clears the 3 flashing lights and brings it to a solid blue light. But as soon as the globe rotates it brings it back to home and all 3 lights are flashing again.(they all flash together).

And by the way, I have also verified the following:

  • the globe is properly aligned into the groove on the base
  • the power supply is original and correct specs
  • the power is plugged in directly to the outlet
  • the litter is not past the fill line

This topic was transferred to internal RobotShop Support.