Low Power / intensity in board CHI035A, PICAXE 18M2 ( SOLVED )

IMG_20121208_192101.jpg (98715Bytes)
IMG_20121208_192123.jpg (63247Bytes)


Hello guys, 


So I have this setup:





What is written at the end of the orange lines are the ports of a bluetooth module, and the ports 0 and 2 in the board are the respective input and output non-buffered ports.


What I'm trying to accomplish here is a robot that follows orders sent from an Android terminal through a bluetooth connection, using a bluetooth module. The robot has two motors to move around the floor or wherever you put it. 


All the bluetooth part receiving and sending data with the Android is solved and works well, but I have some consistent problems now with the power in the board, more concretely the motors.


The motors are these : http://www.pololu.com/catalog/product/61/specs


I also have a buzzer connected to the board, with which I do the testing with the bluetooth although it sounds very weak. The motors, in place of moving or showing any sign of life, the only thing they do is some kind of sharp sound whithout moving. 


At first, everything worked fine, the motors worked as they should, but progressively they have stopped working because of unknown reasons.


I have tested the motors with the batteries, connecting them directly, and they work properly, but when it comes to use them altogether with the board, they just don't work.


A few pics:


Are you using rechargeable batteries?

If so, have you charged them lately?

I’ve just tried that

I’ve just used new batteries but without result. I’ve even used a multimeter to see if the output from the battery pack is correct ,but everything looks okay. The problem seems to reside within the board. I’ve checked all the ports ,but again , nothing…


You can see it by yourself in the datasheet, it’s a pdf and the required information appears in the end of the fourth page.

The L293D is the chip which controls the two motors



To be fair

I can’t make out what the chips are on your board. are you sure you aren’t using any of the drive/enable lines that are supposed to feed the 293?

I don’t really understand what you mean

Are you asking which chips I have on the board? When you refer to the drive/enable lines what do you mean? 

In terms of feeding the motor electrically, it should be working just fine connecting it’s wires to the , B.4 , B.5 , B.6 , B.7

Or you’re implying I must connect it to another power source?




It has been solved

The batteries I had didn’t have enough power, so I changed them. Surprisingly the new batteries I bought weren’t charged either although being new from the store so I used another pack and that solved the problem. Silly problem… 

Anyway, thank you guys.

Battery power problem

Good, it is resolved and now you are not facing more problem with battery power after purchacing another one battery.  However, if battery supply probelm occur again and yet persists, you should use Acer brand for the batteries. It is upon your need which battery should be appropraite for that, but i think Acer brand is well in batteries, especially for Acer rechargeable batteryThese batteries are validating for longer run and design to serve you in better routine.