Litter-Robot III Open Air - About The Hall Effect Sensor

The Hall Effect Sensor is the sensor responsible for the tracking of the globe's position. It's what makes your Litter-Robot so intelligent.

This is a companion discussion topic for the original entry at

Hey, I had this problem, I ordered and replaced the wiring harness, and I still have the exact same problem (the 3 led flashing in sequence).
If I hit reset and then cycle the litterbox rotate but stops just short of getting enough rotation to dump the wastes into the drawer, then it returns to the position correctly and goes and start displaying the error.

But if when it’s at the end of the dumping rotation and about to start rotating back I turn it off, back on again, and hit cycle, it complete the correct dumping procedure, but fails to go back to the home position and stops before hitting it.

If it’s not the hall sensor (as it was just replaced), what else could it be?

Hi there, I’m having the same issue with the Litt Robot Open Air. Did you find a solution after replacing the wire assembly / sensors?

Thank you in advance

Initially, no. Then yesterday it started working. It worked ok all yesterday and was still ok this morning…
What. The. Heck

Update: a few days passed and it is still fine. I would say the problem was fixed, maybe it needed to reset? There was something else obstructing the sensor after reassembly? I don’t know, but it is working

So one day, out of the blue, the same issue happened with our Open Air III, all 3 lights blinking and nothing works.
What happens is that after restart the yellow light stays on for like a couple of minutes, and then all 3 lights start flashing simultaneously.

Over the course of next one month we changed:

  1. Bonet
  2. Globe
  3. DFI kit
  4. Anti-pinch pins
  5. Wiring harness

We literally have a brand new unit, but the problem does not go away.

I’d like to think that I’m too clumsy to put everything back properly and I messed up something during installation, but I’ve done it over and over and the robot still doesn’t work.

Please advise!


So next we changed the motor.
And it started working (wow!), but it is rotating in the WRONG DIRECTION, and it stops upside down with the blue light on, like everything is fine.

What could be the issue?


The wiring harness cables were plugged in to the plastic holder the wrong way.
Switching them solved the problem, everything seems to be working fine now.

TIP to Litter Robot Customer Service:

You may want to suggest replacing the motor in one of the earlier steps of the repair process.
In our case this would’ve saved hundreds of dollars and 1+ month of time and frustration.

Just replaced the wire assembly and triple checked to see that I have the Hall sensors mounted in the plastic clip correctly.

The device still indicates that it cannot find the Home position (sequential lights from right to left). Vince indicates that his unit started out this way, and then started to work properly a couple days later…

Suggestion: send the plastic clip with the Hall sensors attached so there is no confusion. Maybe consider fusing the whole component together. (Clip fitting and Hall sensors).

I’m quite certain that the magnets on the globe are in their proper position, but honestly, I wouldn’t know for certain.

Looking for the next troubleshooting suggestion to get this thing to find the home position (and working correctly).

Please advise

A post was split to a new topic: Hall Effect Sensor Mount Litter-Robot 3