Litter Robot 3 Connect App Setup not working - Can't get past Step 4


I require your help regarding a problem I’m encountering.

I can’t get past Step 4 in the Litter Robot Connect App to onboard my new Litter Robot 3 Connect. Step 4 is “Name your Litter Robot” and when I type in a name and click NEXT, it always says “Failed to Add Server Error”

Hardware concerned:
Litter Robot 3 Connect + iPhone iOS 13

Software concerned:
Litter Robot Connect App

Troubleshooting steps already taken:
I rebooted my router and switched off 5GHz broadcasting
I unplugged the unit from the BASE and waited 15seconds to plug it back in
I turned off the WIFI on my phone and started the Connect App in Airplane Mode
At Step 4, when the name of the robot is asked, I reactivated my cellular data and typed in a name
→ Error Message

My WIFI Name and Passwords meet the requirements (character lengths etc.)

Additional information:
I found many complaints online that people can’t get past 4 in this app. I hope you can help me as a Litter Robot Connect is not worth the money without the connection :wink:.

Thank you so much in advance for your help!

I have the same problem.
Have you an solution?

Not yet I am afraid. I hope someone is going to fix this. Otherwise it doesn’t make sense to keep this Litter Robot if it can’t do more than the previous cheaper version :unamused:
Let us keep up to date if someone finds a solution :+1:

ok lets do this.
is there any support email contact?
i will ask the manufacturer.

Hi @Ijhana and @Kono,

Have you tried deleting and installing the app again?

1 Like

no… I will try it.

1 Like

It actually worked. Can’t believe I haven’t thought of that myself. So simple. I just made sure I have the latest version installed.
THANK YOU!!! Wasted hours on this and now it just took me a couple of minutes :grin:

1 Like

We are glad to hear that!

yes, it works.
thank you very much.

to all who has this problem… delete the app and install again.

1 Like

Hallo, ich habe das gleiche Problem. Die App Installation funktioniert bis Schritt 4. Auch eine Deinstallation hat nichts gebracht. Wir sind schon mehrere Stunden damit beschäftigt und die € 60 Mehrkosten für nichts, sind sehr ärgerlich.

I have deleted the app and then re-installed and still cannot get past step 5. Get to “litter-robot ready / sending key” then get onboarding failed.

1 Like

Hey @lslaten !

Please check out this topic: Litter Robot 3 Connect Onboard fail at last step

1 Like

Having the same problem. I got a new circuit board with wifi.

I have tried with no luck:

  • Got a new QR code from litter robot.
  • Tried the airplane mode work around.
  • Tried a different iphone that never had the app before.
  • upgraded the iphone to iOS 14
  • factory defaulted iphone
  • Tried connecting with a laptop and SSH, TELNET and etc…
  • switching it to “litter robot” wifi manually
  • connecting Bluetooth
  • and on and on…

The app NEVER asked for the local wifi username and password. It try to connect and timeout. I switch it to Litter robot wifi and the next icon lights and I press and it says I am done. But, after that it takes me the screen to start all over again.

1 Like

Hey @blittlej!

Which cellphone/tablet are you using to connect?

High any solution to this, been trying all day, as soon as I switch from the app, to change WiFi to Litter-Robot the app stops

1 Like

Hey @wa72!

Have you tried reinstalling the app? Which cellphone are you using?

Reinstalled, tried different hand sets, iPhones iPads, get to the part where it asks you to go and change WiFi over to litter robot and then go back to the app and it’s crashed

1 Like

Hi again @wa72 !

Since you are using iOS devices, you can try connecting via Bluetooth.

You can simply enable Bluetooth before onboarding. It will skip step 4 - you will not have to leave the app and choose Litter-Robot WiFi. It will go straight to “Connecting this can take a few minutes” and then ask you for your home network!

Bluetooth is already enabled, and connected,

Does not let me skip any screens,

is there a solution to this? I just reinstalled the DFI wires and i am getting stopped at “waiting for litter robot to connect.” i have tried all the suggested solutions and it continues to halt at this step.

1 Like