Is that a dead motor?


On my AL5D the wrist motor is reacting weird. It can move in one direction, but not the other. I can move it back to where it’s supposed to be, and passed that I can feel the resistance. But it doesn’t come back alone. If I manually put it a 2000, and then configure it to move to 500, it will. Nicely. If I configure it to move back to 2000, it will not do anything…

Broken? :-/



Can you disconnect the servo from the bracket so the horn can rotate freely? Unscrew the two or four screws which go through the bracket and into the white horn. Try sending the signals again and see if you have the same issue. If not, then there’s either something with the mechanics (check that the bracket rotates freely), or the signal (which is weird). If it happens without the bracket connected, the last test would be to connect it to a free pin on the SSC-32U and use the SSC-32 Servo Sequencer software to move it. If it still is problematic, then the servo might need to be replaced for an unknown reason (perhaps gears?).

1 Like

I tried all those steps with the same result :frowning: I’m able to turn the white wheel manually on one side, and get it then moved by the sequencer, but when it’s on the other side, I’m not able to get it moved again. I tried to move from the bracket 3 to the bracket 4 without any luck.
Sounds like it’s time for a new motor (and then some forensic surgery!)

Is there options for the replacement? Like, a faster or stronger motor? Or there is just a single option?

Don’t know what’s wrong, but sounds like a gear issue, potentiometer or something else internal. A replacement servo is pretty cheap:

If you want something stronger motor

Remember, when you send position commands, these RC servos don’t have any onboard intelligence to know if they are being blocked, and will continue to try to force. In that situation, if you have it move against the bracket, it will heat up and eventually burn.

1 Like

Ok. So. I opened it :wink:

The metal gears are in good shape.
The motor the potentiometer seems to be fine as when I remove the gears and turn it in the expected position, the motor stops. If I move the arm a bit, the motor starts turning slowly. Faster if I turn further, and will stop if I come back in the expected position. However, this works only in one direction! The motor doesn’t turn at all on the other direction!

Let say, I want to have 1500. If I move the arm to 2000 I can see the motor gear moving in one direction. If I move to 1600, the motor slows down. 1500 it stops. But when I start going to 1400 and 1000, it doesn’t turn on the other side. So I suspect once I forgot to put the controller to 0 and I burned it.

I might try the HS-422 as it seems faster. And anyway the cards are super light so I don’t need that much torque. Let see.

Thanks for sharing your thoughts!

1 Like

That’s honestly not an issue we have encountered much at all. Normally something evident happens like the gears strip, the motor controller burns or it fails completely (microcontroller issue). Partially working is … very rare, and hard to say what happened to cause the issue. Fortunately the arm is incredibly modular so swapping any part is easy and tends to be relatively inexpensive.

1 Like