Is My Arduino Dead?

Is my arduino dead.
i have the Arduino deicimela or whatever.
i have my code and when i verify its say "yep she's good mate, upload er".
but when i go to upload er it sits there for ages the IDE freezes and then to me it says "look here mate lets get something right even though i said its all good, im just not in the mood so im not gonna upload it until you make me feel better". however to anyone else it would look like this:

Binary sketch size: 976 bytes (of a 14336 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

so if anyone can help me that would be great. because the programm im trying to upload is so i have bump sensors for my bucket bot. the previous programm is still on the arduino i cant change it.


Probably not dead
I’ve seen that error before but can’t remember the solution. I do remember that I found the fix on the Arduino forums/site, though.

I heard that it can happen

I heard that it can happen if the program running spams the serial port too fast. Try hitting the arduinos reset button just after you click upload.

i tried reseting the board
i tried reseting the board just after pressing the upload button. nothing.

Check out here


Couple of highlights for the link:

Is the proper COM port selected?

Did you happen to put the bump switches on pins 0 or 1? (It can interfere with uploading the sketch)



Try re-burning the bootloader.

If I remember, this errorcode means that communication between the Arduino software and the chip does´nt work.

you might have burned the chip without letting the magic smoke come out… A new chip is cheap. A parrallell programmer is even cheaper to build. I´m a beginner at electronics, but following the instructions on the arduino site, I built one in less than 30 min.



yay thanks guys you are
yay thanks guys you are awsome my bot now works perfectly and i will post it soon!

So what fixed it? And how
So what fixed it? And how are you programming it?

COM Port
I bet it’s the com port that change

I had similar cases with 2

I had similar cases with 2 different ardu’s throwing different errors…seems that I have to press the reset about 8 times for one and 9 for the other to work.

I kinda wish it was as stable as the picaxes…I’ve never had a single issue with them…cept when I forgot to tie the serin line to ground…ooops

ok yeah its all good the
ok yeah its all good the robot works great. i had the bump sensors on digital pins 0 and 1.
any way i changed that and its working good.

Shhh! We’re supposed to be

Shhh! We’re supposed to be all like, " Arduinos rule, PICAxes drool" and stuff! Fristsy has a complex about them already!

Anyway, all I can say with my massive Arduino experience, is that they are like totally awesome and stuff!


What he said…
I agree. My Arduinos rock.

Another Shhh!

Yeah, I’ve seen similar errors with having the wrong com port checked when I upload. I didn’t even think about the problem with the bump switches on pins 0 and 1. Of course! Shoulda seen that one. :wink: I have a couple different Arduino/Freeduino clone boards, each one liking its very own port address. Whenever I see this error I immediately check which port I’m using (I wrote the port # onto a sticker for each Duino - handy hint if you own multiple duino clones).

Voodoobot - Blasphemy!! :slight_smile: We are supposed to say over and over “Arduino’s Rock!” Keep Fristsy up with his PICAxes at night! :wink: Were these by any chance older Arduino’s? Anything older than a Diecimila sometimes required multiple resets to get them to wake up. I never had one, but had heard some stories…