How to make your first robot

help??? sorry if ia sound like a n00b…
i’m trying to do this… and i’ve run into some trouble programming the motors…

when i do high 4/5/6/7/ and low 4/6/7/5, nothing happens. is there a way to tell if the motors are soldered correctly from the programming editor?

thnx in advance…

The pins correspond to
The pins correspond to different motors. Pins 4 and 5 should run one motor, pins 6 and 7 should run the other. To get the first motor to turn, one of the first 2 pins needs to be high, while the other pin is low. So to get the first motor to turn, set pin 4 high and pin 5 low. If you set pin4 low and pin 5 highg, the motor should turn the other direction. To stop that motor, set them both either high or low. Same thing with pins 6 and 7 for the other motor.

one wheel
Ok, got everything ‘working’ … and no matter how i put in high 4 low 6 high 5 low 7 etc, i can only get one wheel to turn… and thats only if all 4 lines are in. Maybe this is a wiring error? or some other unseen error?

Have you tried high 4 low 5

Have you tried

high 4 low 5 ?

It’s 4&5 and 6&7 that are A and B.

Anyway, try to break it down, and be more precise in your describiton, like “High 4 Low 5 makes motor A run, but…”

Make sure every one step works before moving on; Is the wires hooked up to the motor? Have you tried switching motors? etc… If you are not doing these things by heart, you will have a long way before your robot is serving you coffie :wink:

I haven’t yet made this, but
I haven’t yet made this, but as I was skimming through, I did not see a way to turn this on and off. I could probably figure it out on my own, but I was just curious.

Insert batteries = onTake

Insert batteries = on
Take out batteries = off

or wire a switch between the
or wire a switch between the batteries and the board

i need help
i built the robot and now im trying to program it but when i try to an error message pops up saying i either dont have power, its not connected or i need to reset it, i dont know what to do

There is something

There is something fundementally wrong with your setup then.

The only thing to do is to check that everything is connected, that the chip has power, the cable goes to it etc.

When the cable is installed to yuour computer and the chip is getting power and the cable is connected to the chip, then you will not get this kind of error :slight_smile:

Twin Motor Gearbox
I am a new user and I just had a quick question about a tamiya twin motor gearbox ( Do you think I could use it to build the beginner bot?

It could… However, it would

It could… However, it would not be optimal, as you would get a fast but not so strong robot. (Even in the setting of the gearbox with the highest ratio)

I’d strongly suggest for a beginner to get a high ratio; It is simply more fun to learn that way.

Speaker volume too low to hear
Okay, I spent the whole day building my first robot. Works awesome. However, when I tried to hook up a speaker, the volume is so low, I have to put my ear right next to the speaker to hear the various beeps. Do I need a separate amplifier circuit to get the sound out of the PICAXE controller?

Make a seperate post. This
Make a seperate post. This robot doesn’t use a speak and has over 300 posts so your question will get lost.

Sorry if this has been asked
Sorry if this has been asked before, but when I connect my board to my PC and give the board the command to move the servo, the servo doesn’t move. I’ve checked that i had it in the right way, and it was, but it still didn’t respond. Both the motors and the SRF05 responded fine, but not the servo. What could it be?

not enough turn
I just finished the assembly and coding for my 1st robot based on the lmr “how to make your first robot” instructions… The robot seems to work fine but it cannot turn enough or the motor doesn’t run long enough to make the proper turn after robot decides which way is better…I’m using tamiya twin-motor gearbox… Thanks in advance for any inputs…

You still havent answered my
You still havent answered my problem Below…

This is where you ajust the

This is where you ajust the code.

Try to alter the time that stuff is turned on and off :wink:

**Editor Problem **
I have a problem with the Editor from Picaxe…I bought all pieces indicated above and build everything togehter. Now I wanted to progam my chip board but when I transfer the code the the chip, it says “Couldn’t find Hardware on COM8” (Yes the USB Cable is on COM8). It says I should check if I got power on the chip, or try using the Reset button. Nothing did help… can anyone help me?

To put it short; This is the

To put it short; This is the error message you get if something fundemental is wrong.

You just have to make sure everything is working / has got power etc, one thing at a time. It is a very common error, and it just means that "something basic is wrong".

thank you for your quick
thank you for your quick response

What about the rest of the analogue inputs? the short cut thingy? it does not explain that.

and I am sorry for my stupidity I also did not understand as to which set of pins should i insert the wires to.

All i understood was that which wire goes to which pin. Please help me.