Failed at the first hurdle!

Hello guys,

I'm asking for advice as I've failed at the first hurdle with my Start Here Robot. I thought I would first make an LED flash using the PICAXE chip but so far I cannot connect to the chip to upload the software!

I am using a PICAXE28X1 and an AXE020 project board as bought in the lovely Start Here bundle!

- I've got the chips in place as in the Start Here instructions (only difference is that my resistor chip is a black chip not yellow).
- I've installed PICAXE Programming Editor and the USB Serial Driver.
- In the software I can now go to View > Options and port COM 11 shows as "Ready for Use AXE027 PICAXE USB" (woo hoo!).
- I've got a battery box with four rechargable AA batteries. I checked the voltage was in the 4.5v - 5.0v range (It was about 4.83v).
- I've connected the battery box to the project board using croc clips (no sparks, no smoke)!
- Connect the data cable for the project board
- I click on the "Check Firmware Version..." button and....

Error - Hardware not found on COM 11


I've double checked all my connection, triple checked them and all I can get is the same error message!

Can anyone suggest something I've overlooked?
Could I have fried a chip at some point and if so is there anyway of checking?

Any suggestions would be apreciated as I'm pretty stuck!




If a solid connection is the problem,

are the internals of the jack not tensioned metal that could be ‘adjusted’?

Try a hard reset

So start up the editor and attempt to download your program onto the 28X1. First a box will pop up that says “Dowloading…” and then it will change to “Connecting to hardware…” When it says the connecting part, not before, hit the reset button on the board. Sometimes this will kickstart a difficult chip out of the box; I’ve had to do it before.

edit - on reread you’re stuck getting firmware info. I had it in my head you were at the blinky light stage. I’m not sure the hard reset will work for you but it’s all I have right now :slight_smile:

com ports

Check out the usb manual

I have had problems with that have been solved by changing the com number. And once i had to reinstal the drivers. I don’t know why it is so buggish sometimes.

By the way, Did you remember install the drivers twice?


another tip is that usb cable should be connected before starting programming editor.

If problem is in hardware, very often it turns out that picaxe isn’t getting power. Be sure that conncetions are okay.


But check out the usb cable settings, I have had problems with them. Maybe you have done everything but these are just suggestions, ( is picaxe installed right the holes matching in the socket and chip?) etc. I have too one socket that has connection problems as mentioned above.

the software blows

Some things to know about the Picaxe editor software / com ports:

-the drivers apply only to the current COM port. So once you install the drivers, that usb port should be dedicated to programming, because you’ll have to re-install the drivers every time you remove the cable.

- the software often needs to be “reminded” of the connection with the programming cable. With the picaxe plugged in and powered, open the View > Options dialog and go to the serial port tab. If the cable is plugged in, it should default to that COM. Select a different COM, then re-select the correct one (silly, huh?). Click Apply and try that. (basically what Juchen said).

-are you sure the picaxe is powered? try running the LED (with the resistor ) from a V pin to ground.



Still baffled!

Hello again guys,

Thanks for your suggestions, I’ve taken it apart and checked all the settings you mentioned above.

The culprit was my own stupidity… a jumper in the wrong place!


Thank you for your help.