Error-hardware not found?

Hey LMR,

this is probably some silly thing i missed but i kinda need the answer fairly quick so, uuhh...ya

I'm getting close to finishing my start here robot and i need to get the servo to centre position... (I'm using the usb cord and windows vista basic). I downloaded the picaxe programming editor and the drivers for the usb cord and the cord is showing up when i go to options> serial port>com 4. But when i plug in my picaxe 28x1 to the usb and press check firmware this shows up: 

Hardware not found on com 4:

Possible causes:

1) Hardware  not connected 

I'm pretty sure it is, unless the usb cord is broken, but i JUST bought it so it shouldn't be...

2) Hardware not powered

It should be, i'm using 3 non-rechargebles (1.5 volts) and a dead battery, does that work? Also, i've checked the connections, i think that there ok, but i'm not a great solderer...

3) Hardware needs a reset

Which iv'e done like 10 times...

So i'm stumped.. As i said, i need some possible solutions pretty quick, so if you could help that would be great! thanks


Edit: Here's a photo of my picaxe, hope it helps!


"i’m using 3

"i’m using 3 non-rechargebles (1.5 volts) and a dead battery, does that work?"

Nope, won’t work. Although you’ll get a voltage equal to the sum of all 4 batteries, the dead battery will have a large internal resistance, which will limit the current able to flow through the circuit. Get rid of that dead cell, and use batteries with the same remaining charge where possible.


Kk thx,that might be the problem…I’ll check it out…


No that doesn’t seem to be the problem, i put in some copper pipe and its still not showing up, thanks tho… Any other ideas?

Do you have a multimeter or

Do you have a multimeter or other way to verify the power from the batteries is at least 4.5V?

Is the USB cable you are using the Picaxe programming cable? This is a specific cable that translates the USB signal to and inverted serial signal that the Picaxe uses. If you are using a normal USB to serial cable, it will not work.


Ya i’m using the picaxe programming cable, i bought it with the Start here kit…

right now im letting a friend borrow my multimeter, so i cant use it… On the outside of the batteries i’m using they all say 1.5 volts and i’ve got a battery tester that says that they have power in them…

Thanks!, if you have any other ideas please tell me…

Well, your set up with a

Well, your set up with a copper pipe to complete the battery circuit seems suspect to me. Can you hook the output wires of the battery holder to something that will definitely show you are getting voltage? Like a motor or a 5V lamp or an LED with a 330 ohm resistor in series?


kk ill try it out thx ignoble


I tested the connection with a motor and it seems to work fine, any other ideas?


OK, so it’s probably not

OK, so it’s probably not power, and you are using a Picaxe programming cable. So let’s look for software issues.

Search this site for recognize picaxe hardware or something similar and read through some of the solutions. You’re not the first to have some trouble connecting the Picaxe to the computer initially. Once you get this worked out, you should be fine. I’ll continue to skim some of those search results and see if there’s anything I can suggest.

Good luck.

I went threw the same kind

I went threw the same kind of issue the first time I tried to connect the Picaxe usb download cable.

I can’t remember exactly what the problem was, but I’m sure it was a software configuration issue. When you plug the cable, can you see the new COM Port in the device manager ? Like that (sorry about French language :wink: :


I remember I had to change the port number a few times before it works fine.



Ya it’s showing up there exactly like that, thanks though…I’m sure ill find it eventually


New problem!

Hello LMRians, i think  might have found a possible source of the problem… The power cord that was attached to the picaxe porject board(It was attached by the factory not me) was loose and has now fallen out…I’m not sure if i should try to solder it back in or ask for a replacement… Can you tell me? Here’s a picture:

P.S: It’s the positive connection


the red wire of my picaxe 28

the red wire of my picaxe 28 was also fallen out. I soldered it and there was no problem.

Just make sure you solder it the right way.

Good luck


Ok great i’ll trysoldering it today, thanks a ton!

If you are new to soldering,

If you are new to soldering, there are tons of video tutorials on youtube. Check them out. Five minutes of your time will save you a lot of head aches.


That’s cool you figured out what the problem was !

Now, the real fun can begin :wink:

Enjoy !