Erratic behavior with SSC-32U

I have been working with a Pololu Maestro for a a little bit and everything has worked fine. I ordered an SSC-32 at the recommendation of many people, and I am curious if what I’m experiencing is expected or if I may have a bad board.

In this video

You can see I have 4 MG90S servos hooked up to the SSC32 on channels 4-7. I can move them around using the sliders, however occasionally they will all just randomly go to “zero” it seems. I will then center them for them to center properly only to have them all random move in some wonky direction once again. This isn’t easily repeatable and is pretty inconsistent, but it can happen even after the device is on for 5 minutes, so I doubt its startup errors.

Another question I have is with how laggy the Servo Sequencer seems to be. The software that came with the maestro is very snappy and servos move instantly when I move their slider, but on the SSC32 it seems very sluggish when it is given the command to go somewhere and moves incredibly slowly to get to where I told it. I’m also wondering if there is a way to adjust the servo movement speed on the controller board like there is on the Maestro. I am planning on making some puppets with TrackSkull and VSA, and the servos seem the same when controlled with the joystick, but I would like to be able to slow down the overall speed like I can with the Maestro in the settings.


Welcome to the RobotShop Community.

  1. Can you provide a few clear photos of the electronics, especially the connections and power?
  2. What power supply are you using (voltage and current)?

The Sequencer has two parts:

  • User control (the sliders and knobs, so the speed is whatever you input)
  • Sequences (which include timing)

The other method if you’re ready to do a bit of programming is to use the SSC-32 protocol, where you can send multiple commands on the same line and make use of “modifier” commands like time and speed of the move.

1 Like

I am using a 5V 3A modular power supply. The wires pass through a CAT6 connector board which works just fine on the Mini Maestro. This happens using multiple pin combinations.

The controller works mostly fine using TrackSkull, and also LynxTerm. But when I connect it to the Sequencer, all the servos do this weird zeroing out thing occasionally. I don’t plan on using the sequencer, so its not a big deal, but I don’t like that it doesn’t work the way I expect it to.

I would also like to be able to set the rotation limits if possible like I can on the Maestro board. That way, I set the servo limits on the board itself and I don’t have to set them inside TrackSkull and VSA. Is the SSC32 capable of that? Or does it not actually store that information on the board itself like the Maestro?

You should be able to set the voltage to 6V on the wall adapter.

Q1) Do you know how much current the servos are consuming at any given time?

Q2) Have you tried connecting the servos directly to the SSC-32U without the CAT5 as intermediate electronics? What happens?

If the same connections work for Lynxterm and TrackSkull, it does seem odd that it would not also work with the sequencer.

There are some commands which can be written to the SSC-32U’s onboard microcontroller, but it’s not meant to be “programmable”, just “configurable”. You can read more about it here:

Unfortunately setting the min/max doesn’t seem to be an option, though it really is up to the controller sending the commands to restrict the pulse width.
1 Like

I switched the power supply to 6v, but considering the issue only happens when the Sequencer is open regardless of voltage, I doubt that’s an issue. How do I tell how much current a servo is consuming? And I don’t really see why that would cause this behavior solely in the sequencer but nowhere else.

I plugged some servos straight into some open channels on the ssc32 and get the same result so the cat6 adapter is also no effecting it. Two of these servos are brand new from robotshop.

The servos also seem pretty slow when using the sequencer, and like to buzz even after they’ve hit their mark, is that expected behavior?

I read through the guide, but I didn’t see anything about “configuring” the onboard chip. What section am I looking under? I don’t want it to actually “program” the servos to do anything, I just want to set some configuration limits. Unless I’m just missing something or I have a defective unit, it seems like the Maestro is much better for my purposes. Which is frustrating because it comes so highly recommended in all the places I’ve been reading up on this.

1 Like

How do I tell how much current a servo is consuming?

You would need separate hardware to measure the current consumption.

The servos also seem pretty slow when using the sequencer, and like to buzz even after they’ve hit their mark, is that expected behavior?

No, that’s not normal.

Hmm. not sure where my text went, so I’ll write it here:

Have you tried using the servos without the CAT6 connector board? We have had another user use this or something like it and the issue was that power was not able to reach the servos at a distance. They needed to use the power jumpers to provide power to the receiving end to which the servos are connected. This might explain the issue in that it appears the servos are “browning out”. Read though the guide associated with the CAT5 product to know how to separate the power going to the servos from the transmitting end and add it to the receiving end.

The video I just posted was servos connected directly to the SSC32. Doing the same exact thing even without the CAT6 connecter.

This is a bit of a head scratcher as there does not seem to be any issues with the wiring or electrical configuration. The symptoms are:

  • Slow movement
  • Moving all to 0 without warning

Both of these indicate low power, though on paper your power supply should be sufficient. Can you manually set the baud rate within the software to 9600 and manually select the right COM port then connect (via the software)?

If that does not make a difference, please provide your order or invoice number and we’ll convert this to a support ticket.

1 Like

So I changed the baud rate back to 9600 and it is still doing the same thing.

Here is the Mini Maestro using the same USB cord, same power supply and the cat6 adapter. It has the responsiveness and reliability I would hope to expect from the SSC 32.

We’ve reached out to the designer of the sequencer software to see if he has any thoughts about both issues (lag and erratic behavior).

We got the explanation for the first behavior you’re seeing regarding the delayed motion:

There’s a fixed transition duration of 1 second when moving the sliders. This can be changed by editing the schematic and moving a couple of levels down. See attached pic for location of the appropriate module in FlowBotics Studio.

This is largely because the primary function of the sequencer is just that - creating sequences.

Regarding the second issue, more research will be needed.

1 Like

Is this something I am unable to modify without having my own copy of Flowbotics Studio? IF it’s jsut an issue with the sequencer than I suppose it doesn’t affect me since I wont be using that to program anything, but it was just a bit offputting that this was my first experience with what I expected to be a very reliable piece of equipment.

Correct - since it involves editing the program itself, you’d need FlowBotics. Also correct that the delay is only with the SSC-32 sequencer, not the SSC-32U itself.

1 Like