Dropped USB Connection with AL5D Arm

I have multiple Lynxmotion AL5D Robotic Arms, and have one that continually looses USB communication using either FlowArm or SSC-32 Servo Sequencer Utility. I have tried different PCs and this is the only arm I’m having the issue with. Here is a description of lights at various points in time:

At power on: A- Green, PWR - Blue
FlowArm on/connected: Tx, Rx, and A flash
Disconnect: PWR - Blue

Thanks ahead for any trouble shooting help,

Welcome to the RobotShop Community. Some possible ways to troubleshoot:

  1. Check the arm connected to a different USB port of the same computer
  2. Check the arm with one of the other computers
  3. Uninstall and then reinstall the FTDI VCP driver VCP Drivers - FTDI
  4. Check that the jumpers on the SSC-32 are set identically to the others
  5. Check that the servos (especially the orientation of the connectors to the SSC-32) are good
  6. Triple check the screw terminals on the SSC-32 (VS, VL) and see that there are no loose strands, that they are inserted correctly and properly secured

Await your reply.

1 Like

Hi cbenson-
Thanks for the tips. Here is what I observe.

  1. Same result with various ports
  2. Same result with different computers.
  3. I didn’t do this since it is clearly a problem with this arm only on 2+ different computers.
  4. Same as other working arms. The only jumpers on the board are on the VS1 and VS2 pins.
  5. Ok, here is where it gets interesting. The board stays connected when all servos are disconnected from the board. When any servo is plugged into header 0-5, the board disconnects after a minute or two. Plug direction has been triple checked and known good servos have been used.
  6. VS +/- cut, restripped, and reinstalled.
    Thanks again,
    PS Here is a pic of the board : 20221004_114418.jpg - Google Drive

Can you check the shoulder and elbow joints to see if they are too stiff for the servos? This might be a “brownout” issue where the servos try to draw too much current. This would also be the case with the gripper servo if it cannot move to a angle (physically blocked / incorrectly installed).
Steps 4 and 10 here (the brackets need to rotate freely): AL5D Arm SSC-32U
Step 18 involves the servo and gripper.

1 Like

Thanks again for the ideas. So the joints don’t appear to be overly tight, but I’m definitely having trouble with the turntable, shoulder (the shoulder servo spins CW and never stops if a full CW command is given) and wrist servos. It’s gonna take a while to get to this, but I’m going to tear this arm completely apart and replace all of the servos. I’ll give you an update once I’ve done that.
thanks again,

If a servo seems problematic, disconnect it from the SSC-32U (no need to disassemble yet) and see if the rest of it works. If it does, you’ve likely found a problematic servo, or something’s wrong with how it’s connected (electrically or mechanically). Another note is to check all connections between extension cables and ensure that the pins match (yellow to yellow, black to black etc.).

1 Like