Created App Activation failed


I require your help regarding a problem I’m encountering.

I am desperately trying to created my own app for use on a project using servos and a ssc-32 board. I successfully create the app but I can’t use it due to activation failure. Here are the steps taken.

  1. I setup click create app
  2. I click of get app ID:
  3. I enter the App ID from the field labeled “Test App ID”
    4)I click create
  4. After the app is created, a dialogue box asks to activate the app by entering the activation key, I copy the activation key from the field labeled " App License Key" from the developer website which I received the app id from
  5. I receive the same error every time " Activation failed, check your internet connection,anti -virus and firewall or"

Hardware concerned**:

Software concerned:

Troubleshooting steps already taken:
I have turned off my firewall, my antivirus and even tried a different internet connection same result.
Additional information:

Thank you so much in advance for your help!

@TuPortal Welcome to the RobotShop Community. We can try the app you created on our end and see if we encounter the same issue if you are willing to share it (rest assured RobotShop will not release it) via ZIP file or file sharing site.

1 Like

A HUGE HUGE Thanks for your quick response!

I don’t think the issue is app related, I’ve tried to do a test by just dragging a component to the work area then creating an app. Same result…

Also, we intend to install these apps on specific computers with each computer having specific settings . Therefore we need over 50 versions of this app for each pc that we want to install it on. That means I would have to send you each version every time we want to activate it.
Could it be the activation key related ?
Can you replicate the issue by creating a random app to see if it works for you?
Is there any other way to create an app?
Is there some way around activation? ( other than running it in flowbotics)

Again a HUGE thanks far any help you can provide

Could it be the activation key related ?

FlowBotics Studio was set up a while back to prevent .exe creation using proprietary types like Lynxmotion and Phidgets and relies on the .exe to be created by RobotShop. However you should be able to create .exe files for apps you created.

Is there any other way to create an app?

Unfortunately not.

Is there some way around activation? (other than running it in flowbotics)

Running it on FlowBotics would be a solution, but in terms of exporting a stand-alone app based on an existing Lynxmotion app, it would need to be done by RobotShop. We will see if anything can be done and will get back to you as soon as we have any news.

1 Like

Any new updates?
I must have this app compiled very soon to show to my leadership at our company , otherwise we will be forced to find another alternative. Just to further clarify, the app is STRICKLY for our own internal purposes to help us simulate problems using servos to make faults between data\electrical connections therefore it cannot and will not be sold.
This is huge initiative for us , and It would required us to purchase 100s or ssc-32 boards . The app works great, but if we can’t compile it as an executable, its useless.

Apologies, were waiting for an update from your end:

Q1) Is the app you created derived from a Lynxmotion or other existing app?

Q2) If NOT, can you send the file and we will see if we receive the same error message?

1 Like

Did you ever resolve this?