Connection issue with lynxmotion ps2 v4 controller

I’m currently working on a class project to build a small car with an arduino. I chose the lynxmotion ps2 v4 controller to operate it and it worked flawlessly. It worked so well that other teams doing the same project decided to order the same controller. Only now realizing that all the controllers run on the same frequency and we are controlling each other’s cars. Then all the controllers stopped working. All the receivers will turn on with both LEDs on the receiver being lit, but the LEDs on the controller will flash about 10 times before going blank and not connecting to any receiver. We have changed all the batteries in the remotes and have double checked all wirings. Every library is up to date with the latest code. Some students are using the arduino mega while some are using uno’s. The codes for each have been changed accordingly for each board. The only thing I can think of that could be wrong is that would student team accidentally wired 12v straight to one of the receivers. Could the receiver have sent out a kill code to try and save the remote therefor killing the rest of the remotes since they run on the same frequency? If anyone has found a solution or has happened to as well, please respond. Thanks!

@ZackReynolds Welcome to the RobotShop Community. We are here to help but have never encountered nor heard of a situation like that. Can you try troubleshooting one proper pair of PS2 transmitter + receiver?

  • Ensure minimal / essential wiring with the Arduino
  • Ensure the Arduino and the PS2 are properly powered (check that the PS2 batteries are charged or new)
  • Try a very basic PS2 sample code
  • If the light flashes again, check the sample code to see what it might mean (though not all code has troubleshooting).

Never heard of that.

I tried everything you’ve said an no luck. I ended up switching the arduino and it worked for about 20 seconds until another group turned on their lynxmotion controller and kicked my controller off my receiver. I am starting to believe that it is working properly as in the serial monitor reads “unknown controller found”, but no controller is responding. Im starting to believe some other device is on the same frequency as well. Im currently trying to see if there is a way to change the frequency of the controller and receiver, but no luck so far.

Without modifications to the code, the same PS2 transmitter can work with the same PS2 receiver, so indeed, what you are experiencing is normal. I thought you meant the remotes were “bricked” and could not even work on their own.

I initially thought that might be the case but now I don’t due to being able to connect for about 20 seconds without being kicked off. I could be wrong but my guess is there is another device in the building that might be on the same frequency and is connected to the receiver therefor not allowing the controller to connect. Im going to try and move my laptop and set up outside to see if i can get them to connect while not around any other devices.

It would be really odd for another device to know how to communicate with the PS2 (or send out commands which are somewhat detected by the receiver). Perhaps one of the remote controls has not been turned off?

We have turned off all the remotes and have taken out the batteries to be safe. Unhooked all the receivers but one to try and get it to connect. I will try and upload a video of what the remote and receiver are doing to more accurately show what is going on

I have it hooked up to an arduino by its self. Separated from the car. I have the example code running from the billporter library. No other controllers are active. Could the receiver be bad?

And the controller just continues to blink trying to find the receiver

  1. What code are you using?
  2. Can you confirm your wiring (between the receiver and the Arduino) matches the pinout described in the code?

the code i am using is the example given in the github for the project. The pin layout was correct. There was an additional receiver that one of the other groups in the project ordered and i used it instead of the receiver that came with my controller. My controller instantly connected with the new receiver and worked perfectly, so im assuming something is just messed up with the receiver that came with the controller

Given that there are no moving parts (aside from the buttons), it’s odd that it would fail after some time. For the few issues we encounter, many relate to the transmitter not being turned off and draining the battery, wrong pinout vs. the code or mis-wired the receiver and something happened. Very odd. Is there a chance it short-circuited?

" i used it instead of the receiver that came with my controller. "

Does that mean the receiver you were trying to connect to was not the same one which came with the handheld transmitter? We’ve found over the years that very few PS2 transmitters and receivers are inter-compatible. Even had to create a chart:

taking out the batteries and draining the controller was the first thing i tried and no luck. The receiver i have been having problems with ( and still can not get to work) is the one that came with the controller. Another group that originally ordered the same package as i, had the same problems, so they ordered another receiver pictured here. Im not exactly sure if it is a robotshop reciever or not, but it was compatible with the components and controller i got in my initial package. When switching out the receiver cartridges, i did not change the code or any wiring and the new receiver cartridge worked perfectly. I am attaching a picture of the receiver that worked.

Very odd indeed. This is the first such instance we’re aware of where it worked “for a while” and then stopped.
I guess the new receiver came with an optional RF to USB dongle?

How many Lynxmotion PS2 transmitters were ordered from RobotShop? Do you know when?

Correct. I ordered mine on April 3rd, two additional controllers and receivers were ordered about a week later. One group already has a replacement receiver coming from robotshop and the other group ordered the receiver with the dongle on it. The group that ordered the new receiver with the dongle has since switched to a wired controller, so I am just borrowing their receiver for project presentations tomorrow. I appreciate you helping me troubleshoot the problem.

We can proceed with an RMA for your unit. No clue what might have happened.

Do I understand correctly, that the all of the PS2 V4 controllers are on the same frequency? So, you couldn’t play robot soccer with a group of them, correct? We wanted to do a summer camp with them and have 6 of them playing soccer at the same time.


@Studtmann Correct - you will likely experience issues. These PS2 are mass produced and as such, don’t have any differentiation between models (no specific pairing with a receiver which allows them to be connected to compatible receivers). In addition to this, using the same basic Arduino library means the signals can be understood by other robots. RC devices on the other hand allow you to pair specific handheld transmitters with specific receivers, though you need a different Arduino library and code.

1 Like

Thank you. That makes perfect sense.