Can't connect SSC-32U to PC via Bluetooth


I’m trying to connect my SSC-32U to the PC via Bluetooth however it keeps telling me that I entered the wrong PIN. It appears as “BluetoothBee” on my computer when I look for Bluetooth devices however it prompts me with a PIN input every time I try to add it as a device. I believe the default PIN is 1234. The Baud rate is 9600 on the SSC-32U and I don’t have any serial connections to other devices. Please help.

@Jonathan_Sung Welcome to the RobotShop Community. We cannot find an order in our system based on the email you used here to know which bluetooth module you ordered. Therefore a few notes:

  • The baud rate of the bluetooth module needs to match the baud rate of the SSC-32U (which is 9600 by default), as well as the baud rate of teh device you are trying to connect (computer?)
  • Assuming you’re using the XBee header with a Bluetooth Bee module, it needs to be in the correct orientation.
  • If you’re using a separate Bluetooth module and have connected Tx<-> Rx and Rx<-> Tx and GND<->GND, then see above.

If none of these resolve the issue, please provide a few clear images of the setup so we can see how it’s all wired.

1 Like

Some ideas:

If all of these do not work, please remove the Bluetooth Bee, connect the SSC-32U via USB to the computer and operate the servos, to ensure it’s working.


I’ve reinstalled the FTDI VCP drivers. Followed the guide on the manual and set it to 9600. The board is getting powered. I assume that the Bluetooth Bee baud rate is 9600 since it’s factory new. And I tested it via USB with the LynxTerm software and the servos appear to be moving. The Bluetooth still doesn’t seem to connect.

The part of the board with the VL = VS jumper is hidden below wires in the photo you provided. Can you verify that’s in place?
What’s weird is that your other device (a computer?) is able to detect the Bluetooth module, but just not connect to it. According to the guide, the pairing code should be 1234 (the only other we’re aware of is 0000).

That Bluetooth module has since been discontinued by the manufacturer (DFRobot). The kit is being switches over to the following:

If the above doesn’t resolve it, it seems the SSC-32U is fine, and there’s an issue with the Blueooth module. We would then transfer this to internal support where our RMA department would reach out to you to get the order / invoice number and proceed with the exchange / refund.

The VL=VS jumper is not installed. Would that be necessary for it to work?
Yes, I’ve tried PIN 0000. That also does not work.

Assuming you’re operating at 6V, yes, you can see if it makes a difference and install that jumper.

I’m afraid I don’t have a spare jumper to test it with. However, I’m looking at the store listing image and it doesn’t appear to have one connected.

The RSSI LED also flashes after I turn on the power which indicates that the Bluetooth module is connected to the SSC-32U properly.

Wow. I cannot believe it. I got frustrated and started entering random PINs and it worked! PIN 3333 worked! Thank you for your help today!

Hmm… that is certainly unexpected and what luck. Nowhere in the documentation is that pin mentioned (from what I can tell).